summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-07-02 21:43:44 +0200
committerTérence Clastres2019-07-02 21:43:44 +0200
commit4bf800813493072aea003b02ae11a300b27bf640 (patch)
treeb636bc4e7e88eac8147d75db8748d1086bcd7626
parentadd3a6eda67e8b790ef7b60ee21df37ed4cec2ed (diff)
downloadaur-4bf800813493072aea003b02ae11a300b27bf640.tar.gz
Re-introduce !525 with bad commit removed and !505 with regression fixed by !595
-rw-r--r--PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f12d37d88e1..b28a600913b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,6 +63,21 @@ prepare() {
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/582
git cherry-pick -n b4797956
+ # Mild performance improvements on style changes
+ # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/524
+ # Use only the first commit as the other one causes issues and is reverted
+ git cherry-pick -n fb04dafb
+
+ # st: Only emit ::style-changed on actual changes
+ # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/505
+ # Restore this reverted commit to 3.32 as !505 fixes its introduced style glitches
+ git cherry-pick -n f74c07b9
+
+ # st: Consider non-background properties for ::style-changed
+ # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/595
+ # Fixes style glitches introduced by !505
+ git cherry-pick -n 3ed41da6^..73ae4243
+
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update