summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-07-09 14:36:07 +0200
committerTérence Clastres2019-07-09 14:36:07 +0200
commit4c204c3f3fe31a59ccd0ae6a03a957784f8303e9 (patch)
tree76f18eb2db8a6dfee5d94512339c4fa8a27dc746
parentc338c2d8585d837a5b8b5a1231a2c99018da1381 (diff)
downloadaur-4c204c3f3fe31a59ccd0ae6a03a957784f8303e9.tar.gz
Sync to mutter-performance MR style
-rw-r--r--PKGBUILD88
1 files changed, 68 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05b7bd9f1adc..14fa24671b10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,45 +37,94 @@ pkgver() {
prepare() {
cd $pkgname
+ ### Adding and fetching remotes providing the selected merge-requests
+
git remote add verde https://gitlab.gnome.org/verdre/gnome-shell.git || true
git fetch verde
+
+ ### Merge Requests
+
+ # Merge Request Prototype
+ # Title:
+ # URL:
+ # Type:
+ # Status:
+ # Comment:
+ # git cherry-pick -n first_commit^..last_commit
+ #
+ # Possible Status:
+ # 1. Needs rebase: Conflicts with master branch.
+ # 2. Needs review: Mutter maintainers needs to review the new/updated MR and provide feedback.
+ # 3. Needs changes: MR needs to be adjusted based on maintainers feedback.
+ # 4. Merged: MR approved and it changes commited to master.
+ #
+ # Generally, a MR status oscillate between 2 and 3 and then becomes 4.
+ #
+ # Possible Type:
+ # 1. Improvement: Makes an already existing feature behave better, more efficiently/reliably.
+ # 2. Feature: Adds a new functionality.
+ # 3. Fix: Regression/bug fix only available in master (not backported).
+ # 4. Cleanup: Code styling improvement, function deprecation, rearrangement...
+
# https://gitlab.gnome.org/GNOME/gnome-shell/issues/1084
#patch -Np1 -i ../nvidia-background-workaround.patch
- # Fixes and performance improvements to the extension system
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/96
+
+ # Title: Fixes and performance improvements to the extension system
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/96
+ # Type: 1
+ # Status: 2
+ # Comment:
git cherry-pick -n 39f10eaa^..6e704ee1
- # Refine the app menu a bit
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/406
+ # Title: Refine the app menu a bit
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/406
+ # Type: 2
+ # Status: 4
+ # Comment:
git cherry-pick -n ffaca005^..56a36165
- # iconGrid: Hide children outside allocation loop
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/566
+ # Title: iconGrid: Hide children outside allocation loop
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/566
+ # Type: 1
+ # Status: 4
+ # Comment:
git cherry-pick -n 520cea93
- # appDisp allocation cycle fix
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/581
+ # Title: appDisp allocation cycle fix
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/581
+ # Type: 3
+ # Status: 4
+ # Comment:
git cherry-pick -n c1c45f95
- # iconGrid: Fix animation glitch
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/582
+ # Title: iconGrid: Fix animation glitch
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/582
+ # Type: 3
+ # Status: 4
+ # Comment:
git cherry-pick -n b4797956
- # Mild performance improvements on style changes
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/524
- # Use only the first commit as the other one causes issues and is reverted
+ # Title: Mild performance improvements on style changes
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/524
+ # Type: 1
+ # Status: 4
+ # Comment: Use only the first commit as the other one causes issues and is reverted
git cherry-pick -n fb04dafb
- # st: Only emit ::style-changed on actual changes
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/505
- # Restore this reverted commit to 3.32 as !505 fixes its introduced style glitches
+ # Title: st: Only emit ::style-changed on actual changes
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/505
+ # Type: 1
+ # Status: 4
+ # Comment: Restore this reverted commit to 3.32 as !505 fixes its introduced style glitches
git cherry-pick -n f74c07b9
- # st: Consider non-background properties for ::style-changed
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/595
- # Fixes style glitches introduced by !505
+ # Title: st: Consider non-background properties for ::style-changed
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/595
+ # Type: 3
+ # Status: 4
+ # Comment: Fixes style glitches introduced by !505
git cherry-pick -n 7359e431^..be40de5a
git submodule init
@@ -94,4 +143,3 @@ package() {
# https://bugs.archlinux.org/task/37412
mkdir "$pkgdir/usr/share/gnome-shell/modes"
}
-