summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSung Mingi2022-07-06 23:04:41 +0900
committerSung Mingi2022-07-06 23:04:41 +0900
commit6677f83fc9d84c3a53757d2747e3690f22c788f0 (patch)
tree1fe3af8f5eb5000176f66acbd66688d7460d3b6e
parent31d3d54d0e8b807c518140015fda961d507ab88e (diff)
downloadaur-6677f83fc9d84c3a53757d2747e3690f22c788f0.tar.gz
Sync to gnome-42
Signed-off-by: Sung Mingi <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--mr1884.patch10
-rw-r--r--mr1915.patch29
4 files changed, 16 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6880528d2ea0..0019c3d4f216 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
- pkgver = 42.2+3+g88aa9bec1
+ pkgver = 42.3.1
pkgrel = 1
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
@@ -42,17 +42,17 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=42.2+3+g88aa9bec1
- provides = gnome-shell=1:42.2+3+g88aa9bec1
+ provides = gnome-shell=42.3.1
+ provides = gnome-shell=1:42.3.1
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=88aa9bec1628c598be07094698244d68ef9db41c
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=ed602bdc0f28f1547a2c39d1d7889aa25ea1677a
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
source = mr1884.patch
source = mr1915.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = da73e9bb8199135808e9cb7fa2b9aebd8ed4cfd215fffeb94d919de50e18ab73
- sha256sums = 70981733587a988b846b75e52077e5e986ddd38601667b037d1b0950304ea015
+ sha256sums = cce6fbdf0ee230563c43c096c5137f79412723fc5461ae38a9cea66179440079
+ sha256sums = fae801743a3d245df9f0fe7ef9b816bab879000cc7723f40deb0794d4bfd47b2
pkgname = gnome-shell-performance
depends = accountsservice
diff --git a/PKGBUILD b/PKGBUILD
index 402d1474016b..3361a811e915 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ _merge_requests_to_use=('1884' '1915')
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=42.2+3+g88aa9bec1
+pkgver=42.3.1
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
@@ -38,15 +38,15 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
conflicts=(gnome-shell)
-_commit=88aa9bec1628c598be07094698244d68ef9db41c # tags/42.2^3
+_commit=ed602bdc0f28f1547a2c39d1d7889aa25ea1677a # tags/42.3.1^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
"mr1884.patch"
"mr1915.patch")
sha256sums=('SKIP'
'SKIP'
- 'da73e9bb8199135808e9cb7fa2b9aebd8ed4cfd215fffeb94d919de50e18ab73'
- '70981733587a988b846b75e52077e5e986ddd38601667b037d1b0950304ea015')
+ 'cce6fbdf0ee230563c43c096c5137f79412723fc5461ae38a9cea66179440079'
+ 'fae801743a3d245df9f0fe7ef9b816bab879000cc7723f40deb0794d4bfd47b2')
pkgver() {
cd $_pkgname
diff --git a/mr1884.patch b/mr1884.patch
index f77f2cab9b87..1ebe2111a435 100644
--- a/mr1884.patch
+++ b/mr1884.patch
@@ -2,10 +2,10 @@ Author: Daniel van Vugt <daniel.van.vugt@canonical.com>
Source: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1884
Editor: Sung Mingi <FiestaLake@protonmail.com>
Commit: cac94861037a793a16e6ba2b174ff74837625406
-Last Updated: 04/02/22 (gnome-shell 42.0-1)
+Last Updated: 06/07/22 (gnome-shell 42.3.1-1)
diff --git a/js/ui/appDisplay.js b/js/ui/appDisplay.js
-index 116e9931d..d89ad17e2 100644
+index dd75a09ed..e02971024 100644
--- a/js/ui/appDisplay.js
+++ b/js/ui/appDisplay.js
@@ -202,6 +202,16 @@ var BaseAppView = GObject.registerClass({
@@ -51,7 +51,7 @@ index 116e9931d..d89ad17e2 100644
new Clutter.Margin({
left: hOffset,
right: hOffset,
-@@ -2100,6 +2112,10 @@ class AppViewItem extends St.Button {
+@@ -2106,6 +2118,10 @@ class AppViewItem extends St.Button {
this.fake_release();
}
@@ -63,10 +63,10 @@ index 116e9931d..d89ad17e2 100644
return this._id;
}
diff --git a/js/ui/iconGrid.js b/js/ui/iconGrid.js
-index 362cfda91..13f005d61 100644
+index 599374fa3..826fb1246 100644
--- a/js/ui/iconGrid.js
+++ b/js/ui/iconGrid.js
-@@ -1407,4 +1407,33 @@ var IconGrid = GObject.registerClass({
+@@ -1409,4 +1409,33 @@ var IconGrid = GObject.registerClass({
const layoutManager = this.layout_manager;
return layoutManager.rows_per_page * layoutManager.columns_per_page;
}
diff --git a/mr1915.patch b/mr1915.patch
index 0e6cec5c72f8..adf4e57dd21c 100644
--- a/mr1915.patch
+++ b/mr1915.patch
@@ -2,35 +2,8 @@ Author: Daniel van Vugt <daniel.van.vugt@canonical.com>
Source: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1915
Editor: Sung Mingi <FiestaLake@protonmail.com>
Commit: 6f195a883c84284c4be802f1a74e425ea1264728
-Last Updated: 04/02/22 (gnome-shell 42.0-1)
+Last Updated: 06/07/22 (gnome-shell 42.3.1-1)
-diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
-index c6e64766e..2b5fccd57 100644
---- a/data/theme/gnome-shell-sass/_common.scss
-+++ b/data/theme/gnome-shell-sass/_common.scss
-@@ -35,6 +35,11 @@ $base_border_radius: 8px;
- // radii of things that display over other things, e.g. popovers
- $modal_radius: $base_border_radius*2; // 24px
-
-+// Chroma key to flag when a background-color is always occluded, not visible.
-+// This allows any box-shadow behind it to be rendered more efficiently by
-+// omitting the middle rectangle.
-+$invisible_occluded_bg_color: rgba(3,2,1,0);
-+
- // derived hover colors
- $hover_bg_color: if($variant=='light', darken($bg_color, 3%), lighten($bg_color, 4%));
- $hover_fg_color: if($variant=='light', darken($fg_color, 5%), lighten($fg_color, 4%));
-diff --git a/data/theme/gnome-shell-sass/widgets/_window-picker.scss b/data/theme/gnome-shell-sass/widgets/_window-picker.scss
-index e494f6d8a..7c3a26cd4 100644
---- a/data/theme/gnome-shell-sass/widgets/_window-picker.scss
-+++ b/data/theme/gnome-shell-sass/widgets/_window-picker.scss
-@@ -48,5 +48,6 @@ $window_close_button_padding: 3px;
- .workspace-background {
- // keep in sync with BACKGROUND_CORNER_RADIUS_PIXELS in workspace.js
- border-radius: 30px;
-+ background-color: $invisible_occluded_bg_color;
- box-shadow: 0 4px 16px 4px transparentize(darken($osd_bg_color, 30%), 0.7);
- }
diff --git a/src/st/st-theme-node-drawing.c b/src/st/st-theme-node-drawing.c
index b32c76be2..72745ed66 100644
--- a/src/st/st-theme-node-drawing.c