summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2020-04-04 02:06:58 +0200
committerTérence Clastres2020-04-04 02:06:58 +0200
commit77f0fbdc452209f293ac880c6d04766d0831fd7f (patch)
tree59e0fe6f1c5ba72c41258ddc68db1762ff69c66d
parent93ac71a78ee71d2ab49b4254bb59f42320f13a49 (diff)
downloadaur-77f0fbdc452209f293ac880c6d04766d0831fd7f.tar.gz
Sync to gnome-3-36, pick_mr() patch fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5a4b2e1597..0f9fecc1c176 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell
- pkgver = 3.36.1+1+g1dea3341e
+ pkgver = 3.36.1+19+gdfcc5ffb1
pkgrel = 1
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
@@ -37,9 +37,9 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.36.1+1+g1dea3341e
+ provides = gnome-shell=3.36.1+19+gdfcc5ffb1
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=1dea3341ecdb261005a209eb9b99b1c2a6b9e52e
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=dfcc5ffb1e2b7a8e5ad59b1f83133c06a5b8ff7c
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c4d7a4dc5af1..5898e0bc5afc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ _merge_requests_to_use=() # safe pick
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.36.1+1+g1dea3341e
+pkgver=3.36.1+19+gdfcc5ffb1
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
@@ -32,7 +32,7 @@ groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
install=$pkgname.install
-_commit=1dea3341ecdb261005a209eb9b99b1c2a6b9e52e # tags/3.36.1^1
+_commit=dfcc5ffb1e2b7a8e5ad59b1f83133c06a5b8ff7c # tags/3.36.1^19
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
@@ -53,9 +53,9 @@ pick_mr() {
elif [ "$3" = "revert" ]; then
echo "Reverting $1..."
git revert "$2" --no-commit
- elif [ "$2" = "patch" ]; then
+ elif [ "$3" = "patch" ]; then
echo "Patching $1..."
- patch -Np1 -i "$2"
+ patch -Np1 -i ../"$2"
else
echo "ERROR: wrong argument given: $2"
fi