summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSung Mingi2022-07-06 23:12:34 +0900
committerSung Mingi2022-07-06 23:12:34 +0900
commit818cbad0a60cfe34031ec91fc17ba4fd56a79342 (patch)
tree35125953aab5376f98cd507cfd28f189ce9430f7
parent6677f83fc9d84c3a53757d2747e3690f22c788f0 (diff)
downloadaur-818cbad0a60cfe34031ec91fc17ba4fd56a79342.tar.gz
Fix a broken mr1915
Signed-off-by: Sung Mingi <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mr1915.patch31
3 files changed, 33 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0019c3d4f216..18727e38779f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
pkgver = 42.3.1
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
@@ -52,7 +52,7 @@ pkgbase = gnome-shell-performance
sha256sums = SKIP
sha256sums = SKIP
sha256sums = cce6fbdf0ee230563c43c096c5137f79412723fc5461ae38a9cea66179440079
- sha256sums = fae801743a3d245df9f0fe7ef9b816bab879000cc7723f40deb0794d4bfd47b2
+ sha256sums = 58795bb46aaf1885525758ae5c05263497ec5b67b48803980349cd621b259ef9
pkgname = gnome-shell-performance
depends = accountsservice
diff --git a/PKGBUILD b/PKGBUILD
index 3361a811e915..6122d68ccb2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _merge_requests_to_use=('1884' '1915')
pkgname=gnome-shell-performance
_pkgname=gnome-shell
pkgver=42.3.1
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -46,7 +46,7 @@ source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
sha256sums=('SKIP'
'SKIP'
'cce6fbdf0ee230563c43c096c5137f79412723fc5461ae38a9cea66179440079'
- 'fae801743a3d245df9f0fe7ef9b816bab879000cc7723f40deb0794d4bfd47b2')
+ '58795bb46aaf1885525758ae5c05263497ec5b67b48803980349cd621b259ef9')
pkgver() {
cd $_pkgname
diff --git a/mr1915.patch b/mr1915.patch
index adf4e57dd21c..61de776e0a70 100644
--- a/mr1915.patch
+++ b/mr1915.patch
@@ -1,9 +1,36 @@
Author: Daniel van Vugt <daniel.van.vugt@canonical.com>
Source: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1915
Editor: Sung Mingi <FiestaLake@protonmail.com>
-Commit: 6f195a883c84284c4be802f1a74e425ea1264728
-Last Updated: 06/07/22 (gnome-shell 42.3.1-1)
+Commit: 80c33fcb7a93d9fd66318524522b7c8b8fb7a9bb
+Last Updated: 06/07/22 (gnome-shell 42.3.1-2)
+diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
+index 0b89700b4..8cc09be08 100644
+--- a/data/theme/gnome-shell-sass/_common.scss
++++ b/data/theme/gnome-shell-sass/_common.scss
+@@ -35,6 +35,11 @@ $base_border_radius: 8px;
+ // radii of things that display over other things, e.g. popovers
+ $modal_radius: $base_border_radius*2; // 24px
+
++// Chroma key to flag when a background-color is always occluded, not visible.
++// This allows any box-shadow behind it to be rendered more efficiently by
++// omitting the middle rectangle.
++$invisible_occluded_bg_color: rgba(3,2,1,0);
++
+ // fonts
+ $base_font_size: 11;
+ $text_shadow_color: if($variant == 'light', rgba(255,255,255,0.3), rgba(0,0,0,0.2));
+diff --git a/data/theme/gnome-shell-sass/widgets/_window-picker.scss b/data/theme/gnome-shell-sass/widgets/_window-picker.scss
+index c71adad54..9067a6d4e 100644
+--- a/data/theme/gnome-shell-sass/widgets/_window-picker.scss
++++ b/data/theme/gnome-shell-sass/widgets/_window-picker.scss
+@@ -48,5 +48,6 @@ $window_close_button_padding: 3px;
+ .workspace-background {
+ // keep in sync with BACKGROUND_CORNER_RADIUS_PIXELS in workspace.js
+ border-radius: 30px;
++ background-color: $invisible_occluded_bg_color;
+ box-shadow: 0 4px 16px 4px transparentize(darken($osd_bg_color, 30%), 0.7);
+ }
diff --git a/src/st/st-theme-node-drawing.c b/src/st/st-theme-node-drawing.c
index b32c76be2..72745ed66 100644
--- a/src/st/st-theme-node-drawing.c