summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingi Sung2023-10-10 14:25:10 +0900
committerMingi Sung2023-10-10 14:25:10 +0900
commit84b7d993ce606e0aa8fc065eb73a4cd338c08cd4 (patch)
tree690ad2697582cf5872b14171ab51d524cb88d380
parentbedfad26161e9cfcad63288ee10eb7772b4bc0b0 (diff)
downloadaur-84b7d993ce606e0aa8fc065eb73a4cd338c08cd4.tar.gz
Sync to gnome-45
Signed-off-by: Mingi Sung <dawdleming@gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f26ae51d6ba6..b609a28addd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
- pkgver = 44.5
+ pkgver = 45.0
pkgrel = 1
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
@@ -43,12 +43,13 @@ pkgbase = gnome-shell-performance
optdepends = gst-plugin-pipewire: Screen recording
optdepends = gst-plugins-good: Screen recording
optdepends = power-profiles-daemon: Power profile switching
+ optdepends = python-gobject: gnome-shell-test-tool performance tester
optdepends = switcheroo-control: Multi-GPU support
provides = gnome-shell
- provides = gnome-shell=44.5
- provides = gnome-shell=1:44.5
+ provides = gnome-shell=45.0
+ provides = gnome-shell=1:45.0
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=d49cc6fa355d59d3a4c878ae89885cb1c571bfda
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=2127c62b210f605747e019e6e2abee82516e3ccb
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
b2sums = SKIP
b2sums = SKIP
@@ -73,4 +74,4 @@ pkgname = gnome-shell-performance
depends = mutter
depends = unzip
depends = upower
- depends = libmutter-12.so
+ depends = libmutter-13.so
diff --git a/PKGBUILD b/PKGBUILD
index 49d25cc35a2f..c78d78a9565a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _merge_requests_to_use=()
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=44.5
+pkgver=45.0
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
@@ -74,12 +74,13 @@ optdepends=(
'gst-plugin-pipewire: Screen recording'
'gst-plugins-good: Screen recording'
'power-profiles-daemon: Power profile switching'
+ 'python-gobject: gnome-shell-test-tool performance tester'
'switcheroo-control: Multi-GPU support'
)
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
conflicts=(gnome-shell)
-_commit=d49cc6fa355d59d3a4c878ae89885cb1c571bfda # tags/44.5^0
+_commit=2127c62b210f605747e019e6e2abee82516e3ccb # tags/45.0^0
source=(
"git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
@@ -178,6 +179,7 @@ build() {
}
_check() (
+ export NO_AT_BRIDGE=1 GTK_A11Y=none
export XDG_RUNTIME_DIR="$PWD/rdir"
mkdir -p -m 700 "$XDG_RUNTIME_DIR"
@@ -192,6 +194,6 @@ if [ -n "$_enable_check" ]; then
fi
package() {
- depends+=(libmutter-12.so)
+ depends+=(libmutter-13.so)
meson install -C build --destdir "$pkgdir"
}