summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaren Arterius2018-08-05 02:19:38 +0800
committerSaren Arterius2018-08-05 02:19:38 +0800
commitb39de7275bbe62d091340e79f8d0c0947d3aa980 (patch)
treeaa781c3f292e99f0d208cfe3b779ec54b2efcf3a
downloadaur-b39de7275bbe62d091340e79f8d0c0947d3aa980.tar.gz
first
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD66
-rw-r--r--fix.diff36
3 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1375dc9d4bbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = gnome-shell-performance
+ pkgdesc = The next generation GNOME Shell
+ pkgver = 3.28.3+1+gc7a82db37
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/GnomeShell
+ arch = x86_64
+ groups = gnome
+ license = GPL2
+ makedepends = gtk-doc
+ makedepends = gnome-control-center
+ makedepends = evolution-data-server
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ makedepends = sassc
+ depends = accountsservice
+ depends = gcr
+ depends = gjs
+ depends = gnome-bluetooth
+ depends = upower
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gnome-themes-extra
+ depends = gsettings-desktop-schemas
+ depends = libcanberra-pulse
+ depends = libcroco
+ depends = libgdm
+ depends = libsecret
+ depends = mutter
+ depends = nm-connection-editor
+ depends = unzip
+ depends = gstreamer
+ depends = libibus
+ optdepends = gnome-control-center: System settings
+ optdepends = evolution-data-server: Evolution calendar integration
+ provides = gnome-shell
+ conflicts = gnome-shell
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=6ed21e1ce0c1011b58452df6cdde42f30dd386c4
+ source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ source = fix.diff
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 11dcffae170776140b1f0c9bed90b8df70e8d3c6694b60ab40bb46235e3ad755
+
+pkgname = gnome-shell-performance
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1ee8d09044c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# $Id$
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Flamelab <panosfilip@gmail.com
+
+pkgname=gnome-shell-performance
+_pkgname=gnome-shell
+pkgver=3.28.3+1+gc7a82db37
+pkgrel=1
+pkgdesc="The next generation GNOME Shell"
+url="https://wiki.gnome.org/Projects/GnomeShell"
+arch=(x86_64)
+license=(GPL2)
+depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
+ gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
+ mutter nm-connection-editor unzip gstreamer libibus)
+makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
+ sassc)
+optdepends=('gnome-control-center: System settings'
+ 'evolution-data-server: Evolution calendar integration')
+groups=(gnome)
+provides=(gnome-shell)
+conflicts=(gnome-shell)
+_commit=6ed21e1ce0c1011b58452df6cdde42f30dd386c4 # tags/3.28.3^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ fix.diff)
+sha256sums=('SKIP'
+ 'SKIP'
+ '11dcffae170776140b1f0c9bed90b8df70e8d3c6694b60ab40bb46235e3ad755')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+
+ # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/73/commits
+ git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
+ git fetch vanvugt
+ git cherry-pick 6e838439 || bash
+
+ # Try to fix docs build
+ patch -Np1 -i ../fix.diff
+
+ # Move the plugin to our custom epiphany-only dir
+ sed -i "s/'mozilla'/'epiphany'/g" meson.build
+
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
+}
+
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ # Must exist; FS#37412
+ mkdir "$pkgdir/usr/share/gnome-shell/modes"
+}
+
diff --git a/fix.diff b/fix.diff
new file mode 100644
index 000000000000..81f9b42d7812
--- /dev/null
+++ b/fix.diff
@@ -0,0 +1,36 @@
+diff --git i/docs/reference/shell/meson.build w/docs/reference/shell/meson.build
+index 1469ed422..bf99c9446 100644
+--- i/docs/reference/shell/meson.build
++++ w/docs/reference/shell/meson.build
+@@ -45,6 +45,7 @@ configure_file(
+
+ gnome.gtkdoc('shell',
+ main_sgml: 'shell-docs.sgml',
++ dependencies: [libshell_dep, libshell_menu_dep],
+ src_dir: [
+ join_paths(meson.source_root(), 'src'),
+ join_paths(meson.build_root(), 'src')
+diff --git i/docs/reference/st/meson.build w/docs/reference/st/meson.build
+index fe89b53d4..8fdd4f4b5 100644
+--- i/docs/reference/st/meson.build
++++ w/docs/reference/st/meson.build
+@@ -11,6 +11,7 @@ configure_file(
+
+ gnome.gtkdoc('st',
+ main_sgml: 'st-docs.sgml',
++ dependencies: libst_dep,
+ src_dir: [
+ join_paths(meson.source_root(), 'src', 'st'),
+ join_paths(meson.build_root(), 'src', 'st')
+diff --git i/src/st/meson.build w/src/st/meson.build
+index 97ce6134d..216700fb7 100644
+--- i/src/st/meson.build
++++ w/src/st/meson.build
+@@ -122,6 +122,7 @@ libst = shared_library('st-1.0',
+ sources: st_gir_sources + st_non_gir_sources,
+ c_args: st_cflags,
+ dependencies: [clutter_dep, gtk_dep, croco_dep, x11_dep, m_dep],
++ build_rpath: mutter_typelibdir,
+ install_rpath: mutter_typelibdir,
+ install_dir: pkglibdir,
+ install: true