summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-04-03 23:31:17 +0200
committerTérence Clastres2019-04-03 23:31:17 +0200
commitb79f07d8b5c9376deabf9d6abb485a9b82e3f758 (patch)
treed1b178081c652dcdfd82245649a98d2db3a73c61
parent15c3a6f5780e06250549623a16968daeee913099 (diff)
downloadaur-b79f07d8b5c9376deabf9d6abb485a9b82e3f758.tar.gz
Sync with [extra], fix versioning
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--hack-detached.diff17
3 files changed, 10 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2e4e35f2056..7acadc17f69d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches
- pkgver = 3.32.0+22+g05e55cee2
- pkgrel = 2
+ pkgver = 3.32.0+46+gfea019277
+ pkgrel = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
groups = gnome
@@ -34,16 +34,14 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.32.0+22+g05e55cee2
+ provides = gnome-shell=3.32.0+46+gfea019277
conflicts = gnome-shell
- source = gnome-shell-performance::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=05e55cee23d65206f3c3f2d12f4a4d659061651f
+ source = gnome-shell-performance::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=fea01927720e5d73e14e1649ee36cc6c60835d6f
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
source = https://github.com/endlessm/gnome-shell/commit/11ddabfb22aedb3c35abe06d2cf0205f223cca03.diff
- source = hack-detached.diff
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 53fb32bfe8432e6309d5b1bcf9c2b7f36693b9141778b823f1d7e9c1d3f39425
- sha256sums = 939e81f682ebafd60e86d444e49dbab277fba0f00420466b5ff783568b7dc931
pkgname = gnome-shell-performance
diff --git a/PKGBUILD b/PKGBUILD
index ab9a8b11a9a5..958028bf5fb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
-pkgver=3.32.0+22+g05e55cee2
-pkgrel=2
+pkgver=3.32.0+46+gfea019277
+pkgrel=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
@@ -20,20 +20,17 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
-_commit=05e55cee23d65206f3c3f2d12f4a4d659061651f # master
+_commit=fea01927720e5d73e14e1649ee36cc6c60835d6f # master
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- https://github.com/endlessm/gnome-shell/commit/11ddabfb22aedb3c35abe06d2cf0205f223cca03.diff
- hack-detached.diff)
+ https://github.com/endlessm/gnome-shell/commit/11ddabfb22aedb3c35abe06d2cf0205f223cca03.diff)
sha256sums=('SKIP'
'SKIP'
- '53fb32bfe8432e6309d5b1bcf9c2b7f36693b9141778b823f1d7e9c1d3f39425'
- '939e81f682ebafd60e86d444e49dbab277fba0f00420466b5ff783568b7dc931')
+ '53fb32bfe8432e6309d5b1bcf9c2b7f36693b9141778b823f1d7e9c1d3f39425')
pkgver() {
cd $pkgname
- _manual_bump=22 # horrible temporary workaround to account new versioning
- git describe --tags | sed "s/-/+/g;s/20/$_manual_bump/"
+ git describe --tags | sed "s/-/+/g"
}
prepare() {
@@ -44,12 +41,6 @@ prepare() {
# Requires mutter MR283/commit "clutter-actor: Add detail to captured-event signal [performance]"
# git cherry-pick -n 297a18f2
- # Unbreak switcher
- git cherry-pick -n 31e7f0340fd0bd72f2d9848866b1f432ae82eee8
-
- # Hack around broken detached locations
- patch -Np1 -i ../hack-detached.diff
-
# Hack to fix topicon-* extensions making gnome-shell CPU usage > 50%
patch -Np1 -i ../11ddabfb22aedb3c35abe06d2cf0205f223cca03.diff
diff --git a/hack-detached.diff b/hack-detached.diff
deleted file mode 100644
index 7e340bc4a2ba..000000000000
--- a/hack-detached.diff
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git i/js/misc/weather.js w/js/misc/weather.js
-index aaec36cf4..3b09c28c1 100644
---- i/js/misc/weather.js
-+++ w/js/misc/weather.js
-@@ -183,10 +183,8 @@ var WeatherClient = class {
-
- _onGClueLocationChanged() {
- let geoLocation = this._gclueService.location;
-- let location = GWeather.Location.new_detached(geoLocation.description,
-- null,
-- geoLocation.latitude,
-- geoLocation.longitude);
-+ let location = this._world.find_nearest_city(geoLocation.latitude,
-+ geoLocation.longitude);
- this._setLocation(location);
- }
-