summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingi Sung2022-12-05 03:14:27 +0900
committerMingi Sung2022-12-05 03:17:34 +0900
commitbd8a170cd7e6493be89db535c6ad034944552fd1 (patch)
tree8959e8d1ad643c538a0f7e87fee9ee68201fb601
parent2c5cc4e9d10076f0bbba3db3b2f2b271bcd423d9 (diff)
downloadaur-bd8a170cd7e6493be89db535c6ad034944552fd1.tar.gz
Implement `_enable_check` option
Signed-off-by: Mingi Sung <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD32
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 636878172138..4281be123621 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
pkgver = 43.1+28+g9956f5ea5
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
groups = gnome
license = GPL
- checkdepends = xorg-server-xvfb
makedepends = gtk-doc
makedepends = gnome-control-center
makedepends = evolution-data-server
diff --git a/PKGBUILD b/PKGBUILD
index 052b74f701e3..8ac0e47e4e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,21 @@
# Contributor: Flamelab <panosfilip@gmail.com
-### MERGE REQUESTS SELECTION
-
-# available MR: ()
+### PACKAGE OPTIONS
+## MERGE REQUESTS SELECTION
+# Merge Requests List: ()
_merge_requests_to_use=()
-### IMPORTANT: Do no edit below this line unless you know what you're doing
+## Enable the `check()` operation (Disabled if not set)
+: "${_enable_check:=""}"
+
+### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgname=gnome-shell-performance
_pkgname=gnome-shell
pkgver=43.1+28+g9956f5ea5
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -32,7 +35,9 @@ depends=(accountsservice gcr-4 gjs upower gnome-session gtk4
gnome-disk-utility libsoup3 libgweather-4)
makedepends=(gtk-doc gnome-control-center evolution-data-server
gobject-introspection git meson sassc asciidoc bash-completion)
-checkdepends=(xorg-server-xvfb)
+if [ -n "$_enable_check" ]; then
+ checkdepends=(xorg-server-xvfb)
+fi
optdepends=('gnome-control-center: System settings'
'evolution-data-server: Evolution calendar integration'
'gst-plugins-good: Screen recording'
@@ -128,7 +133,10 @@ build() {
CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
LDFLAGS+=" -Wl,-Bsymbolic-functions"
- arch-meson $_pkgname build -D gtk_doc=true
+ arch-meson $_pkgname build \
+ -D gtk_doc=true \
+ -D tests=$(if [ -n "$_enable_check" ]; then echo "true"; else echo "false"; fi)
+
meson compile -C build
}
@@ -139,10 +147,12 @@ _check() (
meson test -C build --print-errorlogs
)
-check() {
- dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
- bash -c "$(declare -f _check); _check"
-}
+if [ -n "$_enable_check" ]; then
+ check() {
+ dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
+ bash -c "$(declare -f _check); _check"
+ }
+fi
package() {
depends+=(libmutter-11.so)