summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2019-10-09 10:26:31 +0800
committerYour Name2019-10-09 10:26:31 +0800
commitbfbe470404d70f4635d7679c0ec3bb1a84b37ad1 (patch)
treeb9060222c83bc34274a9a0f5f75f15f31a27c737
parent1aa5000bb162e7de7076c9857711aaf2b998e5d1 (diff)
downloadaur-bfbe470404d70f4635d7679c0ec3bb1a84b37ad1.tar.gz
sync to 1 commit before 3.34.1, added option for revert a specific commit, attempt to Crash fix for st_theme_get_custom_stylesheets
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD44
2 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b887ed7d8b68..e2ed18e3cb31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell
- pkgver = 3.34.0+163+g6a6d66486
+ pkgver = 3.34.0+175+g3d39b32a0
pkgrel = 1
- epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
install = gnome-shell-performance.install
arch = x86_64
@@ -38,14 +37,12 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.34.0+163+g6a6d66486
+ provides = gnome-shell=3.34.0+175+g3d39b32a0
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=6a6d66486d3326457260f8d1e4b9937d9396c7c6
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=3d39b32a0b65da23d3e6e1513bd7388afdf0e87a
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- source = 739.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 26c2e9672833e09ff63e314f477897bf67c89fd9769c6b4b73d7300b16afd932
pkgname = gnome-shell-performance
diff --git a/PKGBUILD b/PKGBUILD
index fd1faf0adfb7..a44012057b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,8 @@
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.34.0+163+g6a6d66486
+pkgver=3.34.0+175+g3d39b32a0
pkgrel=1
-epoch=1
pkgdesc="Next generation desktop shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
@@ -23,26 +22,44 @@ groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
install=gnome-shell-performance.install
-_commit=6a6d66486d3326457260f8d1e4b9937d9396c7c6 # master
+_commit=3d39b32a0b65da23d3e6e1513bd7388afdf0e87a # master
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- 739.patch)
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
- 'SKIP'
- '26c2e9672833e09ff63e314f477897bf67c89fd9769c6b4b73d7300b16afd932')
+ 'SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/-/+/g'
}
+hash_of() {
+ git log --oneline --all | grep "$1" | tail -n 1 | awk '{print $1}'
+}
+
+git_cp_by_msg() {
+ # Comment: Saren found a way to fetch hash based on commit name. It's controversial but might be interesting to create a function to call for each MR to not have to update the hash at each>
+ h_first=$(hash_of "$2")
+ if [[ -n "$3" ]]; then
+ h_last=$(hash_of "$3")
+ echo "Found $h_first^$h_last for $1"
+ git cherry-pick -n -Xtheirs $h_first^..$h_last
+ else
+ echo "Found $h_first for $1"
+ git cherry-pick -n -Xtheirs $h_first
+ fi
+}
+
prepare() {
cd $_pkgname
### Adding and fetching remotes providing the selected merge-requests
+ git cherry-pick --abort || true
# git remote add verde https://gitlab.gnome.org/verdre/gnome-shell.git || true
# git fetch verde
+ git remote add 3v1n0 https://gitlab.gnome.org/3v1n0/gnome-shell || true
+ git fetch 3v1n0
### Merge Requests
@@ -68,13 +85,12 @@ prepare() {
# 3. Fix: Regression/bug fix only available in master (not backported).
# 4. Cleanup: Code styling improvement, function deprecation, rearrangement...
- # Empty, because all patches are merged to master as of now
-
- # https://gitlab.gnome.org/GNOME/gnome-shell/issues/1641
- git apply -3 ../739.patch
-
- # Un-broke workspaces
- git revert ff9bb5399b1d22fceaf00c9fc8e0058f24af96cc --no-commit
+ # Title: St theme: use css instance data
+ # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/536
+ # Type: 2
+ # Status: 3
+ # Comment: Crash fix for st_theme_get_custom_stylesheets
+ git_cp_by_msg '!536' 'st-theme: Use CRStyleSheet app_data instead of hash map' 'st-theme: Use glib auto free/ptr features'
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"