summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSung Mingi2022-04-02 14:32:04 +0900
committerSung Mingi2022-04-04 01:05:45 +0900
commitcdb314022e55c4a05e970a571fc9983b87f120d3 (patch)
tree46fba265604e37ec9753a76dfc08240aca0a49a9
parenteaf9a679080ed9d53e79c7f142b35b893695f153 (diff)
downloadaur-cdb314022e55c4a05e970a571fc9983b87f120d3.tar.gz
1:42.0-1
Signed-off-by: Sung Mingi <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD29
-rw-r--r--mr1884.patch102
-rw-r--r--mr1915.patch16
4 files changed, 137 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e9979c0640d..f0d2200120e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
- pkgver = 41.5
- pkgrel = 2
+ pkgver = 42.0
+ pkgrel = 1
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = gnome-shell-performance
depends = accountsservice
depends = gcr
depends = gjs
- depends = gnome-bluetooth
+ depends = gnome-bluetooth-3.0
depends = upower
depends = gnome-session
depends = gtk4
@@ -30,7 +30,7 @@ pkgbase = gnome-shell-performance
depends = libgdm
depends = libsecret
depends = mutter
- depends = nm-connection-editor
+ depends = libnma
depends = unzip
depends = gstreamer
depends = libibus
@@ -38,24 +38,27 @@ pkgbase = gnome-shell-performance
depends = gnome-disk-utility
depends = gst-plugin-pipewire
depends = libsoup3
+ depends = libgweather-4
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=41.5
- provides = gnome-shell=1:41.5
+ provides = gnome-shell=42.0
+ provides = gnome-shell=1:42.0
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=87f944a1d43b8ee2586fdaf16520036dc101cdf6
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=44b4b02c3f772a50e6f8b8fd2dca6d9dc3a98725
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ source = mr1884.patch
source = mr1915.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = b2ceb32e96838351b4942bff6afdbd9cb1fb197c084a957ce30e23812857054c
+ sha256sums = da73e9bb8199135808e9cb7fa2b9aebd8ed4cfd215fffeb94d919de50e18ab73
+ sha256sums = 70981733587a988b846b75e52077e5e986ddd38601667b037d1b0950304ea015
pkgname = gnome-shell-performance
depends = accountsservice
depends = gcr
depends = gjs
- depends = gnome-bluetooth
+ depends = gnome-bluetooth-3.0
depends = upower
depends = gnome-session
depends = gtk4
@@ -65,7 +68,7 @@ pkgname = gnome-shell-performance
depends = libgdm
depends = libsecret
depends = mutter
- depends = nm-connection-editor
+ depends = libnma
depends = unzip
depends = gstreamer
depends = libibus
@@ -73,4 +76,5 @@ pkgname = gnome-shell-performance
depends = gnome-disk-utility
depends = gst-plugin-pipewire
depends = libsoup3
- depends = libmutter-9.so
+ depends = libgweather-4
+ depends = libmutter-10.so
diff --git a/PKGBUILD b/PKGBUILD
index 9e92f50977bb..cf84ec435731 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,24 +12,24 @@
### MERGE REQUESTS SELECTION
# available MR: ('1884' '1915')
-_merge_requests_to_use=('1884' '1915')
+_merge_requests_to_use=('1884')
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=41.5
-pkgrel=2
+pkgver=42.0
+pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
license=(GPL)
-depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gtk4
+depends=(accountsservice gcr gjs gnome-bluetooth-3.0 upower gnome-session gtk4
gnome-settings-daemon gsettings-desktop-schemas libcanberra-pulse
- libgdm libsecret mutter nm-connection-editor unzip gstreamer libibus
- gnome-autoar gnome-disk-utility gst-plugin-pipewire libsoup3)
+ libgdm libsecret mutter libnma unzip gstreamer libibus gnome-autoar
+ gnome-disk-utility gst-plugin-pipewire libsoup3 libgweather-4)
makedepends=(gtk-doc gnome-control-center evolution-data-server
gobject-introspection git meson sassc asciidoc bash-completion)
checkdepends=(xorg-server-xvfb)
@@ -38,13 +38,15 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
conflicts=(gnome-shell)
-_commit=87f944a1d43b8ee2586fdaf16520036dc101cdf6 # tags/41.5^0
+_commit=44b4b02c3f772a50e6f8b8fd2dca6d9dc3a98725 # tags/42.0^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "mr1884.patch"
"mr1915.patch")
sha256sums=('SKIP'
'SKIP'
- 'b2ceb32e96838351b4942bff6afdbd9cb1fb197c084a957ce30e23812857054c')
+ 'da73e9bb8199135808e9cb7fa2b9aebd8ed4cfd215fffeb94d919de50e18ab73'
+ '70981733587a988b846b75e52077e5e986ddd38601667b037d1b0950304ea015')
pkgver() {
cd $_pkgname
@@ -118,13 +120,6 @@ prepare() {
#
# Generally, a MR status oscillate between 2 and 3 and then becomes 4.
- # Title: build: Drop incorrect positional arg
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/-/commit/65450a836ee9e0722a2d4c3327f52345eae293c6
- # Type: 3
- # Status: 4
- # Comment: Fix build with meson 0.61.0
- git cherry-pick -n 65450a836ee9e0722a2d4c3327f52345eae293c6
-
# Title: Fade out whole icons instead of using StScrollViewFade (traditional design)
# URL: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1884
# Type: 1
@@ -133,7 +128,7 @@ prepare() {
# avoid painting everything twice to get it on screen. So this almost
# halves the render time of the icon grid.
# Related: #4367, !1877, #174
- pick_mr '1884'
+ pick_mr '1884' 'mr1884.patch' 'patch'
# Title: Optimize box-shadow rendering (part 2) [chroma key design]
# URL: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1915
@@ -170,6 +165,6 @@ check() {
}
package() {
- depends+=(libmutter-9.so)
+ depends+=(libmutter-10.so)
meson install -C build --destdir "$pkgdir"
}
diff --git a/mr1884.patch b/mr1884.patch
new file mode 100644
index 000000000000..f77f2cab9b87
--- /dev/null
+++ b/mr1884.patch
@@ -0,0 +1,102 @@
+Author: Daniel van Vugt <daniel.van.vugt@canonical.com>
+Source: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1884
+Editor: Sung Mingi <FiestaLake@protonmail.com>
+Commit: cac94861037a793a16e6ba2b174ff74837625406
+Last Updated: 04/02/22 (gnome-shell 42.0-1)
+
+diff --git a/js/ui/appDisplay.js b/js/ui/appDisplay.js
+index 116e9931d..d89ad17e2 100644
+--- a/js/ui/appDisplay.js
++++ b/js/ui/appDisplay.js
+@@ -202,6 +202,16 @@ var BaseAppView = GObject.registerClass({
+ this._scrollView.connect('leave-event', this._onLeave.bind(this));
+ this._scrollView.connect('button-press-event', this._onButtonPress.bind(this));
+
++ // Disable the the fade effect shader. IconGrid does its own fading
++ // that's much faster.
++ this._scrollView.update_fade_effect(
++ new Clutter.Margin({
++ left: 0.0,
++ right: 0.0,
++ top: 0.0,
++ bottom: 0.0,
++ }));
++
+ this._scrollView.add_actor(this._grid);
+
+ const scroll = this._scrollView.hscroll;
+@@ -380,10 +390,12 @@ var BaseAppView = GObject.registerClass({
+ -(this._availWidth - this._grid.layout_manager.pageWidth) / 2);
+ }
+
+- this._scrollView.update_fade_effect(fadeMargin);
+- const effect = this._scrollView.get_effect('fade');
+- if (effect)
+- effect.extend_fade_area = true;
++ this._updateFadeMargin(fadeMargin);
++ }
++
++ _updateFadeMargin(margin) {
++ const pagePos = this._adjustment.value / this._adjustment.page_size;
++ this._grid.updateFade(pagePos, margin);
+ }
+
+ _updateFade() {
+@@ -411,7 +423,7 @@ var BaseAppView = GObject.registerClass({
+ return;
+ }
+
+- this._scrollView.update_fade_effect(
++ this._updateFadeMargin(
+ new Clutter.Margin({
+ left: hOffset,
+ right: hOffset,
+@@ -2100,6 +2112,10 @@ class AppViewItem extends St.Button {
+ this.fake_release();
+ }
+
++ get dragging() {
++ return this._draggable && this._dragging;
++ }
++
+ get id() {
+ return this._id;
+ }
+diff --git a/js/ui/iconGrid.js b/js/ui/iconGrid.js
+index 362cfda91..13f005d61 100644
+--- a/js/ui/iconGrid.js
++++ b/js/ui/iconGrid.js
+@@ -1407,4 +1407,33 @@ var IconGrid = GObject.registerClass({
+ const layoutManager = this.layout_manager;
+ return layoutManager.rows_per_page * layoutManager.columns_per_page;
+ }
++
++ updateFade(pagePosition, fadeMargin) {
++ const pageWidth = this.layout_manager.pageWidth;
++ const fadeOutLeftX = pagePosition * pageWidth + fadeMargin.left;
++ const fadeOutRightX = (pagePosition + 1) * pageWidth - fadeMargin.right;
++
++ let children = [];
++ for (let p = 0; p < this.nPages; p++) {
++ children = children.concat(
++ this.getItemsAtPage(p).filter(c => c.visible && !c.dragging)
++ );
++ }
++
++ children.forEach(child => {
++ const childWidth = child.width;
++ const childLeft = child.x;
++ const childRight = childLeft + childWidth;
++
++ let progress = 0.0;
++
++ if (childLeft < fadeOutLeftX && fadeMargin.left > 0)
++ progress = (fadeOutLeftX - childLeft) / childWidth;
++ else if (childRight > fadeOutRightX && fadeMargin.right > 0)
++ progress = (childRight - fadeOutRightX) / childWidth;
++
++ progress = Math.clamp(progress, 0.0, 1.0);
++ child.set_opacity((1.0 - progress) * 255.0);
++ });
++ }
+ });
diff --git a/mr1915.patch b/mr1915.patch
index 32f2a1cc5227..0e6cec5c72f8 100644
--- a/mr1915.patch
+++ b/mr1915.patch
@@ -2,26 +2,26 @@ Author: Daniel van Vugt <daniel.van.vugt@canonical.com>
Source: https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1915
Editor: Sung Mingi <FiestaLake@protonmail.com>
Commit: 6f195a883c84284c4be802f1a74e425ea1264728
-Last Updated: 03/22/22 (gnome-shell 41.5-1)
+Last Updated: 04/02/22 (gnome-shell 42.0-1)
diff --git a/data/theme/gnome-shell-sass/_common.scss b/data/theme/gnome-shell-sass/_common.scss
-index 9df3d8d43..2fa90dbc2 100644
+index c6e64766e..2b5fccd57 100644
--- a/data/theme/gnome-shell-sass/_common.scss
+++ b/data/theme/gnome-shell-sass/_common.scss
@@ -35,6 +35,11 @@ $base_border_radius: 8px;
-
- $modal_radius:$base_border_radius * 2;
+ // radii of things that display over other things, e.g. popovers
+ $modal_radius: $base_border_radius*2; // 24px
+// Chroma key to flag when a background-color is always occluded, not visible.
+// This allows any box-shadow behind it to be rendered more efficiently by
+// omitting the middle rectangle.
+$invisible_occluded_bg_color: rgba(3,2,1,0);
+
- // non-standard colors
- $bubble_borders_color: lighten($borders_color, if($variant=='light', 0%, 5%));
- // $bubble_borders_color: if($variant == 'light', rgba(255,255,255,0.1), rgba(0,0,0,0.3));
+ // derived hover colors
+ $hover_bg_color: if($variant=='light', darken($bg_color, 3%), lighten($bg_color, 4%));
+ $hover_fg_color: if($variant=='light', darken($fg_color, 5%), lighten($fg_color, 4%));
diff --git a/data/theme/gnome-shell-sass/widgets/_window-picker.scss b/data/theme/gnome-shell-sass/widgets/_window-picker.scss
-index fa3f19194..784391822 100644
+index e494f6d8a..7c3a26cd4 100644
--- a/data/theme/gnome-shell-sass/widgets/_window-picker.scss
+++ b/data/theme/gnome-shell-sass/widgets/_window-picker.scss
@@ -48,5 +48,6 @@ $window_close_button_padding: 3px;