summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-03-18 21:15:16 +0100
committerTérence Clastres2019-03-18 21:35:21 +0100
commitd1ecdae2d0f39f56c411f997f6e96d2cfd0ffa03 (patch)
treef97242708eabe16c06f05c8524515ac8f0040d73
parentcb588bfe3f4228c79fb1c8b5d30c751bd3c604ae (diff)
downloadaur-d1ecdae2d0f39f56c411f997f6e96d2cfd0ffa03.tar.gz
Sync with [extra]
-rw-r--r--PKGBUILD14
-rw-r--r--hack-detached.diff17
2 files changed, 28 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21b75dca6c7b..81c68faffc6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
-pkgver=3.32.0+16+gc5780056a
+pkgver=3.32.0+16+ga84e4d9bc
pkgrel=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -22,9 +22,11 @@ provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
_commit=b7d79a5f063341f1773a9a8a5550a188c04efbda # master
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ hack-detached.diff)
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '939e81f682ebafd60e86d444e49dbab277fba0f00420466b5ff783568b7dc931')
pkgver() {
cd $pkgname
git describe --tags | sed 's/-/+/g'
@@ -45,6 +47,12 @@ prepare() {
sleep 3
fi
+ # Unbreak switcher
+ git cherry-pick -n 31e7f0340fd0bd72f2d9848866b1f432ae82eee8
+
+ # Hack around broken detached locations
+ patch -Np1 -i ../hack-detached.diff
+
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
diff --git a/hack-detached.diff b/hack-detached.diff
new file mode 100644
index 000000000000..7e340bc4a2ba
--- /dev/null
+++ b/hack-detached.diff
@@ -0,0 +1,17 @@
+diff --git i/js/misc/weather.js w/js/misc/weather.js
+index aaec36cf4..3b09c28c1 100644
+--- i/js/misc/weather.js
++++ w/js/misc/weather.js
+@@ -183,10 +183,8 @@ var WeatherClient = class {
+
+ _onGClueLocationChanged() {
+ let geoLocation = this._gclueService.location;
+- let location = GWeather.Location.new_detached(geoLocation.description,
+- null,
+- geoLocation.latitude,
+- geoLocation.longitude);
++ let location = this._world.find_nearest_city(geoLocation.latitude,
++ geoLocation.longitude);
+ this._setLocation(location);
+ }
+