summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaren Arterius2020-03-09 11:58:01 +0800
committerSaren Arterius2020-03-09 11:58:01 +0800
commite932566fa66b75c6bc837474a623ccb7067a2c33 (patch)
tree691267e04b7917c6c2feda77bb0fc8e9ff216c00
parentc33ad2abab26c04a89359f00c9b856407df56baf (diff)
downloadaur-e932566fa66b75c6bc837474a623ccb7067a2c33.tar.gz
3.36, good luck
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD11
2 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cd2d911e5b7..2e69bf589eb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell
- pkgver = 3.34.3
- pkgrel = 4
+ pkgver = 3.36.0
+ pkgrel = 1
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
install = gnome-shell-performance.install
@@ -26,7 +26,6 @@ pkgbase = gnome-shell-performance
depends = gnome-themes-extra
depends = gsettings-desktop-schemas
depends = libcanberra-pulse
- depends = libcroco
depends = libgdm
depends = libsecret
depends = mutter
@@ -38,12 +37,31 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.34.3
+ provides = gnome-shell=3.36.0
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=f7fe7bc676b0cae37405b941822ba9f2b989add6
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=4baa091bc54856b191394c70bcedcd3fb4d1a2b5
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
sha256sums = SKIP
sha256sums = SKIP
pkgname = gnome-shell-performance
+ depends = accountsservice
+ depends = gcr
+ depends = gjs
+ depends = gnome-bluetooth
+ depends = upower
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gnome-themes-extra
+ depends = gsettings-desktop-schemas
+ depends = libcanberra-pulse
+ depends = libgdm
+ depends = libsecret
+ depends = mutter
+ depends = nm-connection-editor
+ depends = unzip
+ depends = gstreamer
+ depends = libibus
+ depends = gnome-autoar
+ depends = libmutter-6.so
diff --git a/PKGBUILD b/PKGBUILD
index 9d8b0044ffb7..eddc606c96de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.34.3
-pkgrel=4
+pkgver=3.36.0
+pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
license=(GPL2)
depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
- gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
+ gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libgdm libsecret
mutter nm-connection-editor unzip gstreamer libibus gnome-autoar)
makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
sassc asciidoc)
@@ -23,7 +23,7 @@ groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
install=$pkgname.install
-_commit=f7fe7bc676b0cae37405b941822ba9f2b989add6 # gnome-3-34
+_commit=4baa091bc54856b191394c70bcedcd3fb4d1a2b5 # tags/3.36.0^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
@@ -146,7 +146,7 @@ prepare() {
git_cp_by_msg '!948' "overviewControls: Use ClutterActor's translation-x"
git submodule init
- git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
git submodule update
}
@@ -156,5 +156,6 @@ build() {
}
package() {
+ depends+=(libmutter-6.so)
DESTDIR="$pkgdir" meson install -C build
}