summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaren Arterius2018-09-18 10:17:53 +0800
committerSaren Arterius2018-09-18 10:17:53 +0800
commite9a4606954be264fcd51a4fdc30ee2e187363477 (patch)
treeeea96b300b96de75bb1f4ca9d9ec02c763d934c5
parentbc63320b981716839bcb4f724e79f778463bfd3f (diff)
downloadaur-e9a4606954be264fcd51a4fdc30ee2e187363477.tar.gz
3.30
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD46
-rw-r--r--fix.diff36
3 files changed, 20 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd3600e4e08b..94b7468817ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
- pkgdesc = The next generation GNOME Shell | Attempt to improve the performance by non-upstreamed patches
- pkgver = 3.28.3+7+g721ce5403
- pkgrel = 2
+ pkgdesc = Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches
+ pkgver = 3.30.0+21+gb087752b5
+ pkgrel = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
groups = gnome
@@ -35,12 +35,10 @@ pkgbase = gnome-shell-performance
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=721ce54037cc07a82927cfdfb7928dadad7d7791
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=b087752b5539a8cbb1d61979cb069aef8a3475be
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- source = fix.diff
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 11dcffae170776140b1f0c9bed90b8df70e8d3c6694b60ab40bb46235e3ad755
pkgname = gnome-shell-performance
diff --git a/PKGBUILD b/PKGBUILD
index 85491618f6f9..42b6812078da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Patched package maintainer: Saren Arterius <saren@wtako.net>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.28.3+7+g721ce5403
-pkgrel=2
-pkgdesc="The next generation GNOME Shell | Attempt to improve the performance by non-upstreamed patches"
+pkgver=3.30.0+21+gb087752b5
+pkgrel=1
+pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
license=(GPL2)
@@ -20,36 +21,21 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell)
conflicts=(gnome-shell)
-_commit=721ce54037cc07a82927cfdfb7928dadad7d7791 # gnome-3-28
+_commit=b087752b5539a8cbb1d61979cb069aef8a3475be # master
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- fix.diff)
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
- 'SKIP'
- '11dcffae170776140b1f0c9bed90b8df70e8d3c6694b60ab40bb46235e3ad755')
+ 'SKIP')
-prepare() {
+pkgver() {
cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
- # js/ui: Choose some actors to cache on the GPU
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/73/commits
- git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
- git fetch vanvugt
- git cherry-pick f77b3da7 || bash
-
- # Javascript invalid access fixes
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/4/commits
- # git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
- # git fetch vanvugt
- # git cherry-pick 78da92c1 || bash
- # git cherry-pick df5ca834 || bash
- # git cherry-pick a667357e || bash
- # git cherry-pick 163e9b43 || bash
- # git cherry-pick 1f820518 || bash
-
+prepare() {
+ cd $_pkgname
- # Try to fix docs build
- patch -Np1 -i ../fix.diff
+ # No patches as of now
# Move the plugin to our custom epiphany-only dir
sed -i "s/'mozilla'/'epiphany'/g" meson.build
@@ -65,9 +51,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
- # Must exist; FS#37412
+ # https://bugs.archlinux.org/task/37412
mkdir "$pkgdir/usr/share/gnome-shell/modes"
}
diff --git a/fix.diff b/fix.diff
deleted file mode 100644
index 81f9b42d7812..000000000000
--- a/fix.diff
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git i/docs/reference/shell/meson.build w/docs/reference/shell/meson.build
-index 1469ed422..bf99c9446 100644
---- i/docs/reference/shell/meson.build
-+++ w/docs/reference/shell/meson.build
-@@ -45,6 +45,7 @@ configure_file(
-
- gnome.gtkdoc('shell',
- main_sgml: 'shell-docs.sgml',
-+ dependencies: [libshell_dep, libshell_menu_dep],
- src_dir: [
- join_paths(meson.source_root(), 'src'),
- join_paths(meson.build_root(), 'src')
-diff --git i/docs/reference/st/meson.build w/docs/reference/st/meson.build
-index fe89b53d4..8fdd4f4b5 100644
---- i/docs/reference/st/meson.build
-+++ w/docs/reference/st/meson.build
-@@ -11,6 +11,7 @@ configure_file(
-
- gnome.gtkdoc('st',
- main_sgml: 'st-docs.sgml',
-+ dependencies: libst_dep,
- src_dir: [
- join_paths(meson.source_root(), 'src', 'st'),
- join_paths(meson.build_root(), 'src', 'st')
-diff --git i/src/st/meson.build w/src/st/meson.build
-index 97ce6134d..216700fb7 100644
---- i/src/st/meson.build
-+++ w/src/st/meson.build
-@@ -122,6 +122,7 @@ libst = shared_library('st-1.0',
- sources: st_gir_sources + st_non_gir_sources,
- c_args: st_cflags,
- dependencies: [clutter_dep, gtk_dep, croco_dep, x11_dep, m_dep],
-+ build_rpath: mutter_typelibdir,
- install_rpath: mutter_typelibdir,
- install_dir: pkglibdir,
- install: true