summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2017-03-06 15:17:43 -0800
committerGavin Lloyd2017-03-06 15:17:43 -0800
commitee50cd4c589bdbdb9a04b5b246320ebd1a948cb5 (patch)
treea01345ccca8f69a420a12b621ceb11ab04223589
downloadaur-gnome-specimen.tar.gz
Init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db3e1cdbfd2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Mar 6 23:17:40 UTC 2017
+pkgbase = gnome-specimen
+ pkgdesc = A simple tool to view and compare fonts installed on your system.
+ pkgver = 0.4
+ pkgrel = 6
+ url = https://download.gnome.org/sources/gnome-specimen
+ arch = any
+ license = GPL
+ makedepends = intltool
+ depends = python2-gconf
+ source = https://download.gnome.org/sources/gnome-specimen/0.4/gnome-specimen-0.4.tar.gz
+ sha256sums = 353ef10e647e5d06354dd827a4152a8cb45bf56b2f1c72e449a41e5175880424
+
+pkgname = gnome-specimen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b599fcd5f81d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: neodreams <yanbrodeur@videotron.ca>
+
+pkgname=gnome-specimen
+pkgver=0.4
+pkgrel=6
+pkgdesc="A simple tool to view and compare fonts installed on your system."
+arch=('any')
+url="https://download.gnome.org/sources/gnome-specimen"
+license=('GPL')
+depends=('python2-gconf')
+makedepends=('intltool')
+source=("$url/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('353ef10e647e5d06354dd827a4152a8cb45bf56b2f1c72e449a41e5175880424')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # GtkSpinButton fix
+ sed -i "s_1\(0<\)_\1_" data/$pkgname.glade
+
+ # Removing unneeded gnome code
+ sed -i "41,45d;59,60d" specimen/main.py
+
+ export PYTHON="/usr/bin/python2"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}