summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdmund2024-06-04 09:59:41 +0200
committerEdmund2024-06-04 09:59:41 +0200
commit62fd185ab93edc01fa31c4c3ecfb2a8296091300 (patch)
treefde1ddf779ac8447eae52d4a261810925fb45dea
parent972362bddf7826279e7367965a5df37b04fff379 (diff)
downloadaur-gnucobol.tar.gz
Updated license description. Omit error to allow build.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f949185eff4..4c50b0ac0574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = gnucobol
pkgdesc = A free, open source and modern COBOL compiler
pkgver = 3.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/gnucobol/
arch = x86_64
- license = GPL
+ license = GPL-3.0-only
makedepends = gcc
depends = db
depends = gmp
+ depends = json-c
+ depends = libxml2
+ depends = ncurses
+ depends = glibc
+ depends = bash
options = !libtool
source = https://ftp.gnu.org/gnu/gnucobol/gnucobol-3.2.tar.xz
source = https://ftp.gnu.org/gnu/gnucobol/gnucobol-3.2.tar.xz.sig
diff --git a/PKGBUILD b/PKGBUILD
index 2e866eb22eb0..5c3c9d75da18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,14 @@
+# Maintainer: Edmund Lodewijks <e.lodewijks@gmail.com>
+# Contributor: Gromit <gromit@archlinux.org>
+
pkgname=gnucobol
pkgver=3.2
pkgdesc="A free, open source and modern COBOL compiler"
-pkgrel=1
+pkgrel=2
arch=("x86_64")
url="https://www.gnu.org/software/gnucobol/"
-license=("GPL")
-depends=("db" "gmp")
+license=("GPL-3.0-only")
+depends=("db" "gmp" "json-c" "libxml2" "ncurses" "glibc" "bash")
makedepends=("gcc")
options=("!libtool")
source=(
@@ -21,7 +24,8 @@ validpgpkeys=(
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --infodir=/usr/share/info
+ # Until fixed, the following CFLAG is added:
+ CFLAGS="$CFLAGS -Wno-error=implicit-function-declaration" ./configure --prefix=/usr --infodir=/usr/share/info
make
}