summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:44:56 +0000
committerXyne2015-06-21 02:44:56 +0000
commit4a4bbff18d449dd75f16b62f4bb27d6d9b48b57d (patch)
tree74b2d1bf597a1a783f0032a65a55db5fb6d0a3e7
downloadaur-4a4bbff18d449dd75f16b62f4bb27d6d9b48b57d.tar.gz
Initial import.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD53
-rw-r--r--gnupg.install21
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e288f271e82e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gnupg1
+ pkgdesc = GNU Privacy Guard - a PGP replacement tool
+ pkgver = 1.4.19
+ pkgrel = 4
+ url = http://www.gnupg.org/
+ install = gnupg.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL3
+ depends = zlib
+ depends = bzip2
+ depends = libldap>=2.4.18
+ depends = libusb-compat
+ depends = curl>=7.16.2
+ depends = readline>=6.0.00
+ source = ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-1.4.19.tar.bz2
+ source = ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-1.4.19.tar.bz2.sig
+ sha1sums = 5503f7faa0a0e84450838706a67621546241ca50
+ sha1sums = SKIP
+
+pkgname = gnupg1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07eb6ef9d49d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 148992 2012-02-05 12:21:23Z andyrtr $
+# Contributor: Andreas Radke <andyrtr at archlinux.org>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+pkgname=gnupg1
+pkgname_=gnupg
+pkgver=1.4.19
+pkgrel=4
+pkgdesc="GNU Privacy Guard - a PGP replacement tool"
+arch=('i686' 'x86_64' 'armv6h')
+license=('GPL3')
+depends=('zlib' 'bzip2' 'libldap>=2.4.18' 'libusb-compat' 'curl>=7.16.2' 'readline>=6.0.00')
+source=("ftp://ftp.gnupg.org/gcrypt/gnupg/$pkgname_-$pkgver.tar.bz2"{,.sig})
+install=gnupg.install
+url="http://www.gnupg.org/"
+sha1sums=('5503f7faa0a0e84450838706a67621546241ca50'
+ 'SKIP')
+validpgpkeys=('D8692123C4065DEA5E0F3AB5249B39D24F25E3B6'
+ '46CC730865BB5C78EBABADCF04376F3EE0856959'
+ '031EC2536E580D8EA286A9F22071B08A33BD3F06'
+ 'D238EA65D64C67ED4C3073F28A861B1C7EFD60D9')
+
+build() {
+ cd "${srcdir}/${pkgname_}-${pkgver}"
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --enable-noexecstack
+ make
+ #ln -s ${pkgname}-${pkgver}/scripts .. # seems obsolete now
+}
+
+check() {
+ cd "$srcdir/$pkgname_-$pkgver"
+ make -k check #All 27 tests passed
+}
+
+package () {
+ cd "${srcdir}/${pkgname_}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Fix file conflicts with gnupg2 pkg. Cd into directories to prevent
+ # unintentional transformation of the full path.
+ cd "$pkgdir/usr/share/man/man1"
+ rename gpg gpg1 gpg*
+
+ cd "$pkgdir/usr/bin"
+ rename gpg gpg1 gpg*
+
+# cd "$pkgdir/usr/share/man/man7"
+# rename gnupg gnupg1 gnupg*
+
+ # Correct multiple renames if makepkg is rerun.
+ find "$pkgdir" -name '*pg11*' -exec rename pg11 pg1 '{}' \+
+}
diff --git a/gnupg.install b/gnupg.install
new file mode 100644
index 000000000000..5a6704716954
--- /dev/null
+++ b/gnupg.install
@@ -0,0 +1,21 @@
+info_dir=/usr/share/info
+info_files=(gnupg1.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+# vim:set ts=2 sw=2 et: