summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2023-06-20 16:13:21 +0200
committerRicardo (XenGi) Band2023-06-20 16:13:21 +0200
commitcb696860bf7fea1ede3f08506b155ee71f5846de (patch)
treedf6ea229c77287c143126682e3191aac39a9a125
downloadaur-go-aws-sso.tar.gz
initial dump
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore111
-rw-r--r--PKGBUILD18
3 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6d91002005f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = go-aws-sso
+ pkgdesc = Make working with AWS SSO on local machines an ease.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/theurichde/go-aws-sso
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ source_x86_64 = https://github.com/theurichde/go-aws-sso/releases/download/v1.3.0/go-aws-sso_1.3.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = a5c34f95983a6e53354cc0767efc25967d119456b32c6aecdaa6ae0f1e9f7f9f
+ source_aarch64 = https://github.com/theurichde/go-aws-sso/releases/download/v1.3.0/go-aws-sso_1.3.0_linux_arm64.tar.gz
+ sha256sums_aarch64 = 608d579edc1c2912068fb484b7d22166b1089bd8251bffe89f03173bddb6ea24
+
+pkgname = go-aws-sso
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39096d79551e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,111 @@
+# Created by https://www.toptal.com/developers/gitignore/api/archlinuxpackages,linux,macos,windows,vim
+# Edit at https://www.toptal.com/developers/gitignore?templates=archlinuxpackages,linux,macos,windows,vim
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Linux ###
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+
+### macOS ###
+# General
+.DS_Store
+.AppleDouble
+.LSOverride
+
+# Icon must end with two \r
+Icon
+
+# Thumbnails
+._*
+
+# Files that might appear in the root of a volume
+.DocumentRevisions-V100
+.fseventsd
+.Spotlight-V100
+.TemporaryItems
+.Trashes
+.VolumeIcon.icns
+.com.apple.timemachine.donotpresent
+
+# Directories potentially created on remote AFP share
+.AppleDB
+.AppleDesktop
+Network Trash Folder
+Temporary Items
+.apdisk
+
+### macOS Patch ###
+# iCloud generated files
+*.icloud
+
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+!*.svg # comment out if you don't need vector files
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+Sessionx.vim
+
+# Temporary
+.netrwhist
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+### Windows ###
+# Windows thumbnail cache files
+Thumbs.db
+Thumbs.db:encryptable
+ehthumbs.db
+ehthumbs_vista.db
+
+# Dump file
+*.stackdump
+
+# Folder config file
+[Dd]esktop.ini
+
+# Recycle Bin used on file shares
+$RECYCLE.BIN/
+
+# Windows Installer files
+*.cab
+*.msix
+*.msm
+*.msp
+
+# Windows shortcuts
+*.lnk
+
+# End of https://www.toptal.com/developers/gitignore/api/archlinuxpackages,linux,macos,windows,vim
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..788635caeeeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ricardo Band <email@ricardo.band>
+pkgname=go-aws-sso
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Make working with AWS SSO on local machines an ease."
+arch=("x86_64" "aarch64")
+url="https://github.com/theurichde/go-aws-sso"
+license=('MIT')
+source_x86_64=("https://github.com/theurichde/go-aws-sso/releases/download/v${pkgver}/go-aws-sso_${pkgver}_linux_amd64.tar.gz")
+source_aarch64=("https://github.com/theurichde/go-aws-sso/releases/download/v${pkgver}/go-aws-sso_${pkgver}_linux_arm64.tar.gz")
+sha256sums_x86_64=('a5c34f95983a6e53354cc0767efc25967d119456b32c6aecdaa6ae0f1e9f7f9f')
+sha256sums_aarch64=('608d579edc1c2912068fb484b7d22166b1089bd8251bffe89f03173bddb6ea24')
+
+package() {
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}
+