summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2019-05-18 11:11:49 +0100
committerGergely Imreh2019-05-18 11:11:49 +0100
commit6cc131605695730f24d91574f12403b1ba60fb76 (patch)
tree360b9093f5e95aa61c808574005172c11eb4ba0a
parent0b10657f9b068f32cf01e76b4eefabdfa3223217 (diff)
downloadaur-6cc131605695730f24d91574f12403b1ba60fb76.tar.gz
Version based on nightlies, update dependencies, optionally precompile proofs
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51731a1df97e..6c91897e324d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Feb 16 22:47:26 UTC 2019
pkgbase = go-filecoin-git
pkgdesc = A decentralized storage network, full node implementation in Go
- pkgver = 0.0.1.r25.g7a875edf
- pkgrel = 2
+ pkgver = nightly_17481_fc53b4_0_gfc53b48c
+ pkgrel = 1
url = https://github.com/filecoin-project/go-filecoin
arch = x86_64
license = MIT
license = Apache-2.0
makedepends = git
makedepends = go>=1.11.2
- makedepends = rust>=1.31.0
makedepends = pkgconf
makedepends = clang
makedepends = jq
+ optdepends = rustup: compiling proofs from scratch
provides = go-filecoin
conflicts = go-filecoin
source = git+https://github.com/filecoin-project/go-filecoin.git
diff --git a/PKGBUILD b/PKGBUILD
index ca0f760af9cc..de8f5b9be569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,15 @@
_pkgname=go-filecoin
pkgname=$_pkgname-git
-pkgver=0.0.1.r25.g7a875edf
-pkgrel=2
+pkgver=nightly_17481_fc53b4_0_gfc53b48c
+pkgrel=1
pkgdesc='A decentralized storage network, full node implementation in Go'
_organization='filecoin-project'
url="https://github.com/$_organization/$_pkgname"
arch=('x86_64')
license=('MIT' 'Apache-2.0')
-makedepends=('git' 'go>=1.11.2' 'rust>=1.31.0' 'pkgconf' 'clang' 'jq')
-optdepends=()
+makedepends=('git' 'go>=1.11.2' 'pkgconf' 'clang' 'jq')
+optdepends=('rustup: compiling proofs from scratch')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+${url}.git")
@@ -24,9 +24,7 @@ sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- VERSION=$(jq -r .version package.json)
- REST=$(git describe --long --tags | sed -e 's/^v//' -e 's/^\(.*\)-\([0-9]*\)-\(g[0-9a-f]*\)$/r\2.\3/')
- printf "%s.%s" "$VERSION" "$REST" | sed -e 's/-//g'
+ git describe --long --tags | sed -e 's/-/_/g'
}
prepare() {
@@ -50,6 +48,11 @@ build() {
msg2 'Installing dependencies...'
cd "$GOPATH/src/github.com/${_organization}/${_pkgname}"
+ if ! command -v rustup > /dev/null; then
+ echo "No rustup, will be using precompiled rust proofs and bls signatures."
+ export FILECOIN_USE_PRECOMPILED_BLS_SIGNATURES=yes
+ export FILECOIN_USE_PRECOMPILED_RUST_PROOFS=yes
+ fi
make deps
msg2 'Building binary...'