summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2021-01-06 03:05:29 +0100
committermorguldir2021-01-06 03:10:47 +0100
commitbd15b48409c48761cd97ea567afccd340790b7ff (patch)
tree363e1f98601849f6b6c493b43eca1b3f12d7fe5c
parent295f114e17890e3a2bc07bc8f2523a25f8849eed (diff)
downloadaur-gobyte-qt.tar.gz
Fix build errors with boost and qpainter
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
-rw-r--r--boostbind.patch12
-rw-r--r--qpainterpath.patch12
4 files changed, 50 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6a6a8ca5800..fa3ae344f296 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gobyte-qt
pkgdesc = Cryptocurrency wallet(QT)
- pkgver = 0.12.2
- pkgrel = 4
+ pkgver = 0.12.2.4
+ pkgrel = 1
url = https://www.gobyte.network/
install = gobyte-qt.install
arch = i686
@@ -20,8 +20,12 @@ pkgbase = gobyte-qt
conflicts = gobyte
source = gobyte-qt::git+https://github.com/gobytecoin/gobyte.git#tag=v0.12.2.4
source = gobyte-qt.desktop
+ source = qpainterpath.patch
+ source = boostbind.patch
sha256sums = SKIP
sha256sums = cfedcb808ba80d55409394db7483709daac526b351ceada402588dab3a83d84b
+ sha256sums = 22b6bb675dc46f4cf0bc5b2d5f2549f52240bc874790f7138c9166e3d49fa863
+ sha256sums = 0648a93bae4c361999484e0001f202ab8525cd04fed848f640708779cc68ae54
pkgname = gobyte-qt
diff --git a/PKGBUILD b/PKGBUILD
index 5f3ac592001d..be642aa47a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: metscoin <mets_coin@outlook.com>
+# Maintainer: morguldir <morugldir@protonmail.com
+# Contributor: metscoin <mets_coin@outlook.com>
pkgname=gobyte-qt
-pkgver=0.12.2
-pkgrel=4
+pkgver=0.12.2.4
+pkgrel=1
arch=('i686' 'x86_64')
url="https://www.gobyte.network/"
license=('MIT')
@@ -11,15 +12,27 @@ depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
makedepends=(boost qt5-tools)
conflicts=(gobyte)
install=gobyte-qt.install
-source=("${pkgname%-git}::git+https://github.com/gobytecoin/gobyte.git#tag=v0.12.2.4"
- "$pkgname.desktop")
+source=("${pkgname%-git}::git+https://github.com/gobytecoin/gobyte.git#tag=v$pkgver"
+ "$pkgname.desktop"
+ "qpainterpath.patch"
+ "boostbind.patch")
+
sha256sums=('SKIP'
- 'cfedcb808ba80d55409394db7483709daac526b351ceada402588dab3a83d84b')
+ 'cfedcb808ba80d55409394db7483709daac526b351ceada402588dab3a83d84b'
+ '22b6bb675dc46f4cf0bc5b2d5f2549f52240bc874790f7138c9166e3d49fa863'
+ '0648a93bae4c361999484e0001f202ab8525cd04fed848f640708779cc68ae54')
-build() {
+prepare()
+{
cd "$srcdir/$pkgname"
+ git apply ../qpainterpath.patch
+ git apply ../boostbind.patch
./autogen.sh
./configure --with-gui=qt5
+}
+
+build() {
+ cd "$srcdir/$pkgname"
make
}
diff --git a/boostbind.patch b/boostbind.patch
new file mode 100644
index 000000000000..f039339e9fd2
--- /dev/null
+++ b/boostbind.patch
@@ -0,0 +1,12 @@
+diff --git a/src/validationinterface.h b/src/validationinterface.h
+index 094eccf..8c5fe43 100644
+--- a/src/validationinterface.h
++++ b/src/validationinterface.h
+@@ -8,6 +8,7 @@
+
+ #include <boost/signals2/signal.hpp>
+ #include <boost/shared_ptr.hpp>
++#include <boost/bind.hpp>
+
+ class CBlock;
+ struct CBlockLocator;
diff --git a/qpainterpath.patch b/qpainterpath.patch
new file mode 100644
index 000000000000..41b7d8b51a54
--- /dev/null
+++ b/qpainterpath.patch
@@ -0,0 +1,12 @@
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+index bf89b92..104c3b5 100644
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -8,6 +8,7 @@
+ #include <boost/bind.hpp>
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QColor>
+ #include <QTimer>
+