summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Hofer2020-03-06 16:48:51 -0500
committerJeremy Hofer2020-03-06 16:48:51 -0500
commit13bbc6fe758522229dbd85ee27e03750ef0350b3 (patch)
tree680fb4095b93343ca5b86419275f43dcfb8cde52
downloadaur-13bbc6fe758522229dbd85ee27e03750ef0350b3.tar.gz
ADD initial build for godot v3.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26da68432316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = godot-headless-export-templates-bin
+ pkgdesc = A headless version of the latest official release of the Godot engine and all export templates.
+ pkgver = 3.2
+ pkgrel = 1
+ url = http://www.godotengine.org
+ arch = x86_64
+ license = MIT
+ provides = godot
+ conflicts = godot
+ conflicts = godot-git
+ source = https://downloads.tuxfamily.org/godotengine/3.2/Godot_v3.2-stable_linux_headless.64.zip
+ source = https://downloads.tuxfamily.org/godotengine/3.2/Godot_v3.2-stable_export_templates.tpz
+ md5sums = 3cb27200df9e9cef5db8e20bb115e3bb
+ md5sums = 0d4f433aea7e9b88235ccc3c26f34de6
+
+pkgname = godot-headless-export-templates-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcda8f33fbb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jeremy Hofer <fuego0607@gmail.com>
+pkgname=godot-headless-export-templates-bin
+pkgver=3.2
+pkgrel=1
+pkgdesc="A headless version of the latest official release of the Godot engine and all export templates."
+arch=("x86_64")
+url="http://www.godotengine.org"
+license=("MIT")
+provides=("godot")
+conflicts=("godot" "godot-git")
+source=(
+ "https://downloads.tuxfamily.org/godotengine/${pkgver}/Godot_v${pkgver}-stable_linux_headless.64.zip"
+ "https://downloads.tuxfamily.org/godotengine/${pkgver}/Godot_v${pkgver}-stable_export_templates.tpz"
+)
+md5sums=(
+ "3cb27200df9e9cef5db8e20bb115e3bb"
+ "0d4f433aea7e9b88235ccc3c26f34de6"
+)
+
+package() {
+ install -D -m755 "${srcdir}/Godot_v${pkgver}-stable_linux_headless.64" "${pkgdir}/usr/bin/godot"
+ install -d -m644 "${pkgdir}/usr/share/godot/templates/${pkgver}.stable"
+ cp "${srcdir}/templates/"* "${pkgdir}/usr/share/godot/templates/${pkgver}.stable"
+}