summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoJoS2015-06-21 00:57:30 +0200
committerJoJoS2015-06-21 00:57:30 +0200
commitf0785277f879d3cf6e51a970535522a36fc51ca9 (patch)
treebb664aa9d3ab59e299b843bc3aa5800f61bd9f65
downloadaur-gog-deponia-2-chaos-on-deponia.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
-rwxr-xr-xgog-deponia-2-chaos-on-deponia5
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..739125abbfaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gog-deponia-2-chaos-on-deponia
+ pkgdesc = Rufus is not a pleasant guy. Ill-tempered and entirely too convinced of his own greatness, he lives at the edge of a small settlement somewhere in the most remote sector of the garbage-covered planet Deponia. GOG linux game package required!
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/deponia_2_chaos_on_deponia
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = desktop-file-utils
+ source = local://gog_deponia_2_chaos_on_deponia_1.0.0.1.tar.gz
+ source = gog-deponia-2-chaos-on-deponia
+ md5sums = c231dd926257bc2cf9849d82e711e808
+ md5sums = 2b15664c975ed0f2b7a1142700627274
+
+pkgname = gog-deponia-2-chaos-on-deponia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f67135b8adb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : JoJos
+
+pkgname=gog-deponia-2-chaos-on-deponia
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="Rufus is not a pleasant guy. Ill-tempered and entirely too convinced of his own greatness, he lives at the edge of a small settlement somewhere in the most remote sector of the garbage-covered planet Deponia. GOG linux game package required!"
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/deponia_2_chaos_on_deponia"
+license=("custom")
+groups=("games")
+source=("local://gog_deponia_2_chaos_on_deponia_${pkgver}.tar.gz" "gog-deponia-2-chaos-on-deponia")
+md5sums=('c231dd926257bc2cf9849d82e711e808'
+ '2b15664c975ed0f2b7a1142700627274')
+depends=(libgl libx11 libxext desktop-file-utils)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/deponia-2-chaos-on-deponia
+ cp -r "${srcdir}"/Deponia\ 2\ -\ Chaos\ on\ Deponia/* "${pkgdir}"/opt/gog/deponia-2-chaos-on-deponia
+ install -Dm644 "${srcdir}"/Deponia\ 2\ -\ Chaos\ on\ Deponia/support/gog-deponia-2-chaos-on-deponia-primary.desktop "${pkgdir}"/usr/share/applications/gog-deponia-2-chaos-on-deponia.desktop
+ install -Dm644 "${srcdir}"/Deponia\ 2\ -\ Chaos\ on\ Deponia/support/gog-deponia-2-chaos-on-deponia.png "${pkgdir}"/usr/share/pixmaps/gog-deponia-2-chaos-on-deponia.png
+ install -Dm644 "${srcdir}"/Deponia\ 2\ -\ Chaos\ on\ Deponia/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-deponia-2-chaos-on-deponia" "${pkgdir}/usr/bin/gog-deponia-2-chaos-on-deponia"
+}
diff --git a/gog-deponia-2-chaos-on-deponia b/gog-deponia-2-chaos-on-deponia
new file mode 100755
index 000000000000..66d900b1809d
--- /dev/null
+++ b/gog-deponia-2-chaos-on-deponia
@@ -0,0 +1,5 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/deponia-2-chaos-on-deponia"
+
+"$gogdir"/start.sh
+