summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2022-11-30 18:55:32 -0500
committerSandy Carter2022-11-30 18:55:32 -0500
commit16a73190102926d035753d2206b96229c1e2a2b2 (patch)
tree30da5dead7e02afe5550836c0c746fcda7d9e59a
parente1aa2f54fb4e964605254cf12db1d4617c51ab4b (diff)
downloadaur-16a73190102926d035753d2206b96229c1e2a2b2.tar.gz
UnionFS: Remove use_ino and nonempty
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD2
-rwxr-xr-xgog-heroes-of-might-and-magic-3-complete-edition2
-rwxr-xr-xgog-heroes-of-might-and-magic-3-complete-edition-campaign-editor2
-rwxr-xr-xgog-heroes-of-might-and-magic-3-complete-edition-hd-mod2
-rwxr-xr-xgog-heroes-of-might-and-magic-3-complete-edition-hota2
-rwxr-xr-xgog-heroes-of-might-and-magic-3-complete-edition-map-editor2
7 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0014a0cdb239..427feee786c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gog-heroes-of-might-and-magic-3-complete-edition
pkgdesc = Heroes of Might & Magic III and its expansions: Armageddon's Blade and The Shadow of Death (with optional HD patch)
pkgver = 4.0.28740
- pkgrel = 5
+ pkgrel = 6
url = https://www.gog.com/game/heroes_of_might_and_magic_3_complete_edition
arch = i686
arch = x86_64
@@ -32,4 +32,3 @@ pkgbase = gog-heroes-of-might-and-magic-3-complete-edition
sha256sums = 493ef7009c2f4d103ed5b283fcc5dd900ff13cfb1d494052227bf7760fe0f7c7
pkgname = gog-heroes-of-might-and-magic-3-complete-edition
-
diff --git a/PKGBUILD b/PKGBUILD
index 9d3c5d62b51e..7206848f778c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=gog-heroes-of-might-and-magic-3-complete-edition
pkgver=4.0.28740
-pkgrel=5
+pkgrel=6
_gamename=${pkgname#gog-}
_gamename=${_gamename//-/_}
#INCLUDE_HD_MOD=true
diff --git a/gog-heroes-of-might-and-magic-3-complete-edition b/gog-heroes-of-might-and-magic-3-complete-edition
index 6b9f0babfd8a..bb92a5b741e7 100755
--- a/gog-heroes-of-might-and-magic-3-complete-edition
+++ b/gog-heroes-of-might-and-magic-3-complete-edition
@@ -21,7 +21,7 @@ then
fi
if ! mountpoint "${UNIONFS_MNT}"
then
- if ! unionfs -o cow,allow_other,relaxed_permissions,use_ino,suid,dev,nonempty ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
+ if ! unionfs -o cow,allow_other,relaxed_permissions,suid,dev ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
then
echo "Failed to mount unionfs" >&2
exit 1
diff --git a/gog-heroes-of-might-and-magic-3-complete-edition-campaign-editor b/gog-heroes-of-might-and-magic-3-complete-edition-campaign-editor
index 20e2b65bf70c..6baef570bc5b 100755
--- a/gog-heroes-of-might-and-magic-3-complete-edition-campaign-editor
+++ b/gog-heroes-of-might-and-magic-3-complete-edition-campaign-editor
@@ -11,7 +11,7 @@ then
fi
if ! mountpoint "${UNIONFS_MNT}"
then
- if ! unionfs -o cow,allow_other,relaxed_permissions,use_ino,suid,dev,nonempty ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
+ if ! unionfs -o cow,allow_other,relaxed_permissions,suid,dev ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
then
echo "Failed to mount unionfs" >&2
exit 1
diff --git a/gog-heroes-of-might-and-magic-3-complete-edition-hd-mod b/gog-heroes-of-might-and-magic-3-complete-edition-hd-mod
index 68299a54be3a..b980f03cc471 100755
--- a/gog-heroes-of-might-and-magic-3-complete-edition-hd-mod
+++ b/gog-heroes-of-might-and-magic-3-complete-edition-hd-mod
@@ -21,7 +21,7 @@ then
fi
if ! mountpoint "${UNIONFS_MNT}"
then
- if ! unionfs -o cow,allow_other,relaxed_permissions,use_ino,suid,dev,nonempty ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
+ if ! unionfs -o cow,allow_other,relaxed_permissions,suid,dev ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
then
echo "Failed to mount unionfs" >&2
exit 1
diff --git a/gog-heroes-of-might-and-magic-3-complete-edition-hota b/gog-heroes-of-might-and-magic-3-complete-edition-hota
index 21de145cc807..4bb7aa47c633 100755
--- a/gog-heroes-of-might-and-magic-3-complete-edition-hota
+++ b/gog-heroes-of-might-and-magic-3-complete-edition-hota
@@ -21,7 +21,7 @@ then
fi
if ! mountpoint "${UNIONFS_MNT}"
then
- if ! unionfs -o cow,allow_other,relaxed_permissions,use_ino,suid,dev,nonempty ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
+ if ! unionfs -o cow,allow_other,relaxed_permissions,suid,dev ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
then
echo "Failed to mount unionfs" >&2
exit 1
diff --git a/gog-heroes-of-might-and-magic-3-complete-edition-map-editor b/gog-heroes-of-might-and-magic-3-complete-edition-map-editor
index 200194551e8a..1144ae5a57d8 100755
--- a/gog-heroes-of-might-and-magic-3-complete-edition-map-editor
+++ b/gog-heroes-of-might-and-magic-3-complete-edition-map-editor
@@ -11,7 +11,7 @@ then
fi
if ! mountpoint "${UNIONFS_MNT}"
then
- if ! unionfs -o cow,allow_other,relaxed_permissions,use_ino,suid,dev,nonempty ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
+ if ! unionfs -o cow,allow_other,relaxed_permissions,suid,dev ${DATA_DIR}=RW:${SOURCE}=RO "${UNIONFS_MNT}"
then
echo "Failed to mount unionfs" >&2
exit 1