summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLamar Pavel2017-05-31 17:06:37 +0200
committerLamar Pavel2017-05-31 17:06:37 +0200
commit73b10d138b7b7d81e08c64997b97a08d9b2d6367 (patch)
treed4cb59df435691d88b1ce8bc57c527b2a14a0b7b
downloadaur-gog-luftrausers.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
-rwxr-xr-xgog-luftrausers4
-rw-r--r--gog-luftrausers.desktop12
5 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b0b7cc92c47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gog-luftrausers
+ pkgdesc = Fast paced 2D air combat game from Vlambeer
+ pkgver = 2.0.0.3
+ pkgrel = 1
+ url = https://www.gog.com/game/luftrausers
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = flac
+ depends = freetype2
+ depends = libogg
+ depends = sdl2
+ depends = libsndfile
+ depends = libvorbis
+ depends = zlib
+ depends = openal
+ provides = luftrausers
+ source = gog://gog_luftrausers_2.0.0.3.sh
+ source = gog-luftrausers
+ source = gog-luftrausers.desktop
+ sha512sums = 351321ef2f932593f861df8d83bf0b406db231295eaef3d328089826c7cf10977985c83fbc909f69760d1e1ce2e6fbf60eec09bceaa7da1d26d2e4713f2f0ffa
+ sha512sums = 8fafd9fdf8e007cfa652daa6698978b2bf6f0d64d7bf6f4681b9741f95ceda4a20ee24105b42dbc24df7de1d28cff77d8035a65ed9c4d3fa0b199feb190d64d9
+ sha512sums = 3cbb5b24ee770134f617bc25c32d78538c58cbfb2b5d55a0c8208054b6807df287d3993fe3d9be76a491a76a2b24d62b24c08f658e9c65a3c2586279f47bf1a9
+
+pkgname = gog-luftrausers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d874ad67cc88
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d743162dbcca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: lamarpavel
+
+pkgname=gog-luftrausers
+_original="Luftrausers"
+pkgver=2.0.0.3
+pkgrel=1
+pkgdesc="Fast paced 2D air combat game from Vlambeer"
+arch=('i686' 'x86_64')
+url="https://www.gog.com/game/luftrausers"
+license=('custom')
+depends=('flac' 'freetype2' 'libogg' 'sdl2' 'libsndfile' 'libvorbis' 'zlib')
+depends_x86_64=('openal')
+provides=('luftrausers')
+DLAGENTS+=("gog::/usr/bin/echo Could not find %u. Manually download it to \"$(pwd)\", or set up a gog:// DLAGENT in /etc/makepkg.conf.")
+source=("gog://${pkgname//-/_}_$pkgver.sh"
+ "$pkgname"
+ "$pkgname.desktop")
+sha512sums=('351321ef2f932593f861df8d83bf0b406db231295eaef3d328089826c7cf10977985c83fbc909f69760d1e1ce2e6fbf60eec09bceaa7da1d26d2e4713f2f0ffa'
+ '8fafd9fdf8e007cfa652daa6698978b2bf6f0d64d7bf6f4681b9741f95ceda4a20ee24105b42dbc24df7de1d28cff77d8035a65ed9c4d3fa0b199feb190d64d9'
+ '3cbb5b24ee770134f617bc25c32d78538c58cbfb2b5d55a0c8208054b6807df287d3993fe3d9be76a491a76a2b24d62b24c08f658e9c65a3c2586279f47bf1a9')
+PKGEXT=".pkg.tar"
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname"
+ cp -r data/noarch/* "$pkgdir/opt/$pkgname"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 data/noarch/support/icon.png "$pkgdir/usr/share/pixmaps/hicolor/256x256/$pkgname.png"
+ install -Dm644 data/noarch/docs/End\ User\ License\ Agreement.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/gog-luftrausers b/gog-luftrausers
new file mode 100755
index 000000000000..12f2dafc5139
--- /dev/null
+++ b/gog-luftrausers
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gogdir="/opt/gog-luftrausers"
+"${gogdir}/start.sh"
diff --git a/gog-luftrausers.desktop b/gog-luftrausers.desktop
new file mode 100644
index 000000000000..7bb328f8933b
--- /dev/null
+++ b/gog-luftrausers.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Luftrausers
+GenericName=Luftrausers
+Comment=Luftrausers
+Icon=/opt/gog-luftrausers/support/icon.png
+Exec=/opt/gog-luftrausers/start.sh
+Categories=Game;
+Path="/opt/gog-luftrausers"
+