summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2024-03-31 22:19:09 +0200
committerClaudia2024-03-31 22:19:09 +0200
commitc51f3a5f0894644f5287aa6eea6176f2e1c5f108 (patch)
treeef2d8741edd0ce0c4e9b976117e93f015c36e356
downloadaur-gog-scott-whiskers-in-the-search-for-mr-fumbleclaw.tar.gz
gog-scott-whiskers-in-the-search-… v1.0.155.72227
-rw-r--r--.SRCINFO25
-rw-r--r--.editorconfig23
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD77
-rw-r--r--gog-scott-whiskers-in-the-search-for-mr-fumbleclaw.desktop10
-rw-r--r--scott-whiskers-in-the-search-for-mr-fumbleclaw.bash7
6 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..106e539ab211
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = gog-scott-whiskers-in-the-search-for-mr-fumbleclaw
+ pkgdesc = Point-and-click adventure about cats, Star Trek, and life itself. GOG version.
+ pkgver = 1.0.155.72227
+ pkgrel = 1
+ url = https://www.gog.com/en/game/scott_whiskers_in_the_search_for_mr_fumbleclaw
+ arch = x86_64
+ license = LicenseRef-eula
+ makedepends = lgogdownloader
+ depends = bash
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk2
+ depends = gtk3
+ depends = pango
+ options = !strip
+ source = scott-whiskers-in-the-search-for-mr-fumbleclaw_1.0.155_(72227).sh::gogdownloader://1259892701/en3installer0
+ source = gog-scott-whiskers-in-the-search-for-mr-fumbleclaw.desktop
+ source = scott-whiskers-in-the-search-for-mr-fumbleclaw.bash
+ sha512sums = d14550a392ca5c79e1556e6bd1cf0c5340f44a7400dd551289b211effbeea5d5e242dbb7ea1d73abd9933ffc6ea9a0bba1636234bd8995291694a0a4b7c2144b
+ sha512sums = 7787d3e167d34485fbda0cca87c97c879f427a8f4b7e55a5d376eb1e70efab2b15b4a93877486ecb0f50ce044c0f0ae521a810d225e4f007ac0c80c0838881d7
+ sha512sums = 5875d36b43bb583e47fceffa821955d2410d92bbe62fa7c74260c5a7df4e6e014101bbc6589a0b609000b5ba9d465e3251a0dc1c259cce16c743800321296d8e
+
+pkgname = gog-scott-whiskers-in-the-search-for-mr-fumbleclaw
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..984630ae4a3e
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,23 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.bash]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa7ddfe6fee1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/.vscode/
+/src
+/pkg
+*.log
+*.pkg.*
+*.tar.*
+*.zip
+scott-whiskers-in-the-search-for-mr-fumbleclaw_*.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae2cf8e8473b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=gog-scott-whiskers-in-the-search-for-mr-fumbleclaw
+pkgver=1.0.155.72227
+pkgrel=1
+pkgdesc='Point-and-click adventure about cats, Star Trek, and life itself. GOG version.'
+_shortname="${pkgname#gog-}"
+arch=('x86_64')
+url="https://www.gog.com/en/game/${_shortname//-/_}"
+license=('LicenseRef-eula')
+depends=(
+ 'bash'
+ 'cairo'
+ 'gdk-pixbuf2'
+ 'glib2'
+ 'glibc'
+ 'gtk2'
+ 'gtk3'
+ 'pango'
+)
+makedepends=('lgogdownloader')
+options=('!strip')
+_setup_basename="${_shortname}_${pkgver%.*}_(${pkgver##*.})"
+
+# Need to hard-code the ID because lgogdownloader would force a prompt
+# whenever we attempt to download `scott_whiskers_in_the_search_for_mr_fumbleclaw`
+# while our GOG account also owns `scott_whiskers_in_the_search_for_mr_fumbleclaw_demo`
+_gog_id='1259892701'
+
+source=(
+ "${_setup_basename}.sh::gogdownloader://${_gog_id}/en3installer0"
+ "${pkgname}.desktop"
+ "${_shortname}.bash"
+)
+
+sha512sums=(
+ 'd14550a392ca5c79e1556e6bd1cf0c5340f44a7400dd551289b211effbeea5d5e242dbb7ea1d73abd9933ffc6ea9a0bba1636234bd8995291694a0a4b7c2144b'
+ '7787d3e167d34485fbda0cca87c97c879f427a8f4b7e55a5d376eb1e70efab2b15b4a93877486ecb0f50ce044c0f0ae521a810d225e4f007ac0c80c0838881d7'
+ '5875d36b43bb583e47fceffa821955d2410d92bbe62fa7c74260c5a7df4e6e014101bbc6589a0b609000b5ba9d465e3251a0dc1c259cce16c743800321296d8e'
+)
+
+DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+PKGEXT=.pkg.tar
+
+prepare() {
+ # Remove unneeded 32-bit binaries
+ # Fixes false alarms in rebuild-detector
+ rm -rfv "${srcdir}/data/noarch/support/yad/32"
+}
+
+package() {
+ echo >&2 'Packaging license'
+ install -D -m 644 -T \
+ "${srcdir}/data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/End User License Agreement.txt"
+
+ echo >&2 'Packaging game icon'
+ install -D -m 644 -T \
+ "${srcdir}/data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ echo >&2 'Packaging game data'
+ mkdir -p "${pkgdir}/opt/${_shortname}"
+ cp -R --preserve=mode \
+ "${srcdir}"/data/noarch/* \
+ "${pkgdir}/opt/${_shortname}"
+
+ echo >&2 'Packaging launcher'
+ install -D -m 755 -T \
+ "${srcdir}/${_shortname}.bash" \
+ "${pkgdir}/usr/bin/${_shortname}"
+
+ echo >&2 'Packaging desktop file'
+ install -D -m 755 -T \
+ "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/gog-scott-whiskers-in-the-search-for-mr-fumbleclaw.desktop b/gog-scott-whiskers-in-the-search-for-mr-fumbleclaw.desktop
new file mode 100644
index 000000000000..860ed25be2de
--- /dev/null
+++ b/gog-scott-whiskers-in-the-search-for-mr-fumbleclaw.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Scott Whiskers in: the Search for Mr. Fumbleclaw
+Comment=Point-and-click adventure about cats, Star Trek, and life itself
+Exec=scott-whiskers-in-the-search-for-mr-fumbleclaw
+Icon=gog-scott-whiskers-in-the-search-for-mr-fumbleclaw
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;
+Encoding=UTF-8
diff --git a/scott-whiskers-in-the-search-for-mr-fumbleclaw.bash b/scott-whiskers-in-the-search-for-mr-fumbleclaw.bash
new file mode 100644
index 000000000000..f3f9998f6c93
--- /dev/null
+++ b/scott-whiskers-in-the-search-for-mr-fumbleclaw.bash
@@ -0,0 +1,7 @@
+#!/usr/bin/env bash
+set -eu
+
+PKGNAME='scott-whiskers-in-the-search-for-mr-fumbleclaw'
+echo >&2 "Launching app"
+cd "/opt/${PKGNAME}"
+exec ./start.sh "$@"