summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorruniq2017-01-29 13:08:01 +0100
committerruniq2017-01-29 13:08:01 +0100
commit4d852ff9d79ad5f4492ac323c4cbf058d60780ee (patch)
treee00969f6e2c1ccf53adcc2a25cf5421903c83c8a
downloadaur-gog-starbound.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
-rw-r--r--gog-starbound13
-rw-r--r--gog-starbound.desktop10
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..378c653895cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-starbound
+ pkgdesc = An extraterrestrial sandbox adventure game
+ pkgver = 2.11.0.12
+ pkgrel = 1
+ url = http://www.playstarbound.com
+ arch = i686
+ arch = x86_64
+ license = custom
+ optdepends = firejail: Automatically sandbox this application from your OS
+ source = gog://gog_starbound_2.11.0.12.sh
+ source = gog-starbound.desktop
+ source = gog-starbound
+ sha256sums = aca83ef0ff7c5c569daff65c678fe9ce4f0dd2bed23a2d3904ee8e75357940ac
+ sha256sums = a6a270b19c6561a60f491781521ab5e3d216013c95a3a66d58fb05680064682c
+ sha256sums = 0aaedd7aeafcb26d090e37d099d4b56e0119026d9bad67df77804ae62c115655
+
+pkgname = gog-starbound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25a2b881b6f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Patrice Peterson <runiq@archlinux.us>
+# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
+
+pkgname=gog-starbound
+pkgver=2.11.0.12
+pkgrel=1
+pkgdesc="An extraterrestrial sandbox adventure game"
+url="http://www.playstarbound.com"
+license=('custom')
+arch=('i686' 'x86_64')
+# If Firejail is installed, this application will be sandboxed automatically.
+optdepends=('firejail: Automatically sandbox this application from your OS')
+source=(
+ "gog://${pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop"
+ "$pkgname")
+sha256sums=('aca83ef0ff7c5c569daff65c678fe9ce4f0dd2bed23a2d3904ee8e75357940ac'
+ 'a6a270b19c6561a60f491781521ab5e3d216013c95a3a66d58fb05680064682c'
+ '0aaedd7aeafcb26d090e37d099d4b56e0119026d9bad67df77804ae62c115655')
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u Download the GOG file to \"$PWD\" or set up a gog:// DLAGENT.")
+
+# Prevent compressing final package
+PKGEXT=".pkg.tar"
+
+package(){
+ cd "${srcdir}"
+
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+
+
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ install -Dm755 "data/noarch/start.sh" \
+ "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/gog-starbound b/gog-starbound
new file mode 100644
index 000000000000..b88df1fddc72
--- /dev/null
+++ b/gog-starbound
@@ -0,0 +1,13 @@
+#! /bin/sh
+
+run="/opt/gog-starbound/start.sh"
+# The launcher fails unless in its dir.
+#cd "$(dirname "$run")" || exit 1
+
+if which firejail >/dev/null 2>&1 && [ -z "$FIREJAIL_IGNORE" ]; then
+ echo "Firejail detected. Enforcing a sandbox"
+ echo "To bypass Firejail enforcement, run FIREJAIL_IGNORE=1 $run."
+ firejail --caps.drop=all "$run"
+else
+ "$run"
+fi
diff --git a/gog-starbound.desktop b/gog-starbound.desktop
new file mode 100644
index 000000000000..dc0eebe5c608
--- /dev/null
+++ b/gog-starbound.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Starbound
+Comment=An extraterrestrial sandbox adventure game
+Exec=gog-starbound
+Icon=gog-starbound
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8