summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorruniq2017-06-03 10:52:49 +0200
committerruniq2017-06-03 10:59:27 +0200
commitd5047fdea6d6d7fbeedcf657ccbd6808fc1e96fa (patch)
treec69cbb644ef0497cb1e6f79601af885c6f9eb171
downloadaur-gog-torchlight2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
-rw-r--r--gog-torchlight212
-rw-r--r--gog-torchlight2.desktop11
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c3e21d68eca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-torchlight2
+ pkgdesc = An action RPG dungeon crawler
+ pkgver = 2.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/torchlight_ii
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom:commercial
+ source = gog://gog_torchlight_2_2.0.0.1.sh
+ source = gog-torchlight2.desktop
+ source = gog-torchlight2
+ sha512sums = 56c47950aebf87886b42e7037801788223ddbf76b124abc61d6eb70ce402435650b7b47aeee1e976fc9fed7150b3dba07d97c4dc2e4034443af3b61f900de5de
+ sha512sums = f85e8fa535e739f620819998acfb663b7fa7645978c7a5e7f56f16c2f447c1aff0c457b65699e849c101d1d4c93c3221797941621b7882beedf99b8e6eb7228b
+ sha512sums = c68c5a015bb75ae520d34f0e5f94309462db8ea6159f8a22b3d2842def37800229c6a5c1c37e09ed9c7d570abf8e89340781bb17ed0ad2ae61508b7abd3be97a
+
+pkgname = gog-torchlight2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7295624ce28e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Patrice Peterson <runiq@archlinux.us>
+
+# This package is based on the gog-terraria package and the gog-freedom-planet package from Ainola.
+
+pkgname=gog-torchlight2
+_pkgname=gog-torchlight-2
+pkgver=2.0.0.1
+pkgrel=1
+pkgdesc='An action RPG dungeon crawler'
+arch=("i686" "x86_64")
+url='http://www.gog.com/game/torchlight_ii'
+license=('custom:commercial')
+groups=('games')
+source=("gog://${_pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop"
+ "${pkgname}")
+sha512sums=('56c47950aebf87886b42e7037801788223ddbf76b124abc61d6eb70ce402435650b7b47aeee1e976fc9fed7150b3dba07d97c4dc2e4034443af3b61f900de5de'
+ 'f85e8fa535e739f620819998acfb663b7fa7645978c7a5e7f56f16c2f447c1aff0c457b65699e849c101d1d4c93c3221797941621b7882beedf99b8e6eb7228b'
+ 'c68c5a015bb75ae520d34f0e5f94309462db8ea6159f8a22b3d2842def37800229c6a5c1c37e09ed9c7d570abf8e89340781bb17ed0ad2ae61508b7abd3be97a')
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
+
+# If you want to use lgogdownloader
+# DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+# source=("gogdownloader://shovel-knight/en3installer4" "${pkgname}.desktop")
+
+# Prevent compressing final package
+PKGEXT='.pkg.tar'
+
+package() {
+ cd "$srcdir"
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "data/noarch/game" "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 "data/noarch/start.sh" \
+ "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/gog-torchlight2 b/gog-torchlight2
new file mode 100644
index 000000000000..e23dbaacad34
--- /dev/null
+++ b/gog-torchlight2
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+run='/opt/gog-torchlight2/start.sh'
+cd /opt/gog-crawl # The launcher fails unless in its dir.
+
+if which firejail >/dev/null 2>&1 && [ -z "$FIREJAIL_IGNORE" ]; then
+ echo "Firejail detected. Enforcing a sandbox"
+ echo "To bypass Firejail enforcement, run FIREJAIL_IGNORE=1 $run."
+ firejail --caps.drop=all "$run"
+else
+ "$run"
+fi
diff --git a/gog-torchlight2.desktop b/gog-torchlight2.desktop
new file mode 100644
index 000000000000..48f1fa1b423f
--- /dev/null
+++ b/gog-torchlight2.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Torchlight 2
+GenericName=Torchlight 2
+Comment=An action RPG dungeon crawler
+Exec=gog-torchlight2
+Icon=gog-torchlight2
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game;AudioVideo;