summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZacharias Knudsen2021-01-04 09:35:25 +0100
committerZacharias Knudsen2021-01-04 09:35:25 +0100
commit4e5c8eddb2a3587e3a94de8bad98f98c28f3f343 (patch)
tree06635f3e5b7b2ee7278d2867692e085fdb54f9e4
parentf56bbba677f785c758c464f8eb02843598062d0a (diff)
downloadaur-4e5c8eddb2a3587e3a94de8bad98f98c28f3f343.tar.gz
Fix symlink pointing to
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD45
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e950d9212864..728c1f5ed086 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gog-unreal-tournament-goty
pkgdesc = Unreal Tournament (99): Game of the Year Edition. GOG Version.
pkgver = 2.0.0.5
- pkgrel = 5
+ pkgrel = 6
url = https://www.gog.com/game/unreal_tournament_goty
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 64b77f7a4594..62ac52bda8b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=gog-unreal-tournament-goty
pkgver=2.0.0.5
-pkgrel=5
+pkgrel=6
pkgdesc="Unreal Tournament (99): Game of the Year Edition. GOG Version."
arch=('x86_64')
url="https://www.gog.com/game/unreal_tournament_goty"
@@ -10,7 +10,7 @@ license=('MIT' 'BSD' 'ZLIB' 'GPL2' 'LGPL2.1' 'ZLIB' 'OFL' 'Apache' 'custom')
depends=('lib32-sdl'
'lib32-libgl')
makedepends=('innoextract')
-source=("setup_ut_goty_$pkgver.exe::gogdownloader://unreal_tournament_goty/en1installer0"
+source=("setup_ut_goty_${pkgver}.exe::gogdownloader://unreal_tournament_goty/en1installer0"
"https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469a/OldUnreal-UTPatch469a-Linux.tar.bz2"
"gog-unreal-tournament-goty.desktop")
noextract=("OldUnreal-UTPatch469a-Linux.tar.bz2")
@@ -20,36 +20,43 @@ sha256sums=("4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803"
# If you want to use lgogdownloader add the following to /etc/makepkg.conf
# DLAGENTS+=('goggogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
-DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find setup_ut_goty_$pkgver.exe (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf.")
+DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find setup_ut_goty_${pkgver}.exe (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf.")
prepare() {
# extract gog installer
- innoextract --extract --exclude-temp setup_ut_goty_$pkgver.exe
+ innoextract --extract --exclude-temp "setup_ut_goty_${pkgver}.exe"
# extract linux patches
- tar --extract --file OldUnreal-UTPatch469a-Linux.tar.bz2 --directory app
+ tar --extract --file "OldUnreal-UTPatch469a-Linux.tar.bz2" --directory "app"
# To put extra content (extra levels/mods) into the game
# create an "addons/" folder next to the PKGBUILD.
# Whatever is in there will get copied to the root of the game's directory.
- cp -r $startdir/addons/* app/ 2>/dev/null || :
+ cp --archive ${startdir}/addons/* "app" 2>/dev/null || :
}
package() {
# make destination directories
- mkdir -p "$pkgdir/opt/gog"
- mkdir -p "$pkgdir/usr/bin"
+ mkdir --parents \
+ "${pkgdir}/opt/gog" \
+ "${pkgdir}/usr/bin"
# copy game files
- cp -r app "$pkgdir/opt/gog/${pkgname#gog-}"
-
- # fix permissions
- chmod 777 -R $pkgdir/opt/gog/${pkgname#gog-}
-
- # symlink ut binary which is located in /opt
- ln --symbolic "$pkgdir/opt/gog/${pkgname#gog-}/System/ut-bin" "$pkgdir/usr/bin/$pkgname"
-
- # install desktop and license
- install -D --mode 644 --target-directory "$pkgdir/usr/share/applications" $pkgname.desktop
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" app/LICENSE.md
+ cp --archive "app" "${pkgdir}/opt/gog/${pkgname#gog-}"
+
+ # fix permissions (too extreme? what files actually need this?)
+ chmod 777 -R "${pkgdir}/opt/gog/${pkgname#gog-}"
+
+ # symlink game binary which is located in /opt
+ ln --symbolic \
+ "/opt/gog/${pkgname#gog-}/System/ut-bin" \
+ "${pkgdir}/usr/bin/${pkgname}"
+
+ # install desktop entry and license document
+ install -D --mode 644 \
+ "${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications"
+ install -D --mode 644 \
+ "app/LICENSE.md" \
+ "${pkgdir}/usr/share/licenses/${pkgname}"
}