summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2019-04-04 17:15:15 -0400
committerJean-Francois Chevrette2019-04-04 17:15:15 -0400
commit4ae25923ef4003aec8ced94d090fd6a6694a1734 (patch)
tree0f61ba7e6426de1cd7c6f8b81a768c2ec5404b6e
downloadaur-gojsontoyaml-git.tar.gz
initial comit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c63b81c11128
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gojsontoyaml-git
+ pkgdesc = Simple tool to convert json to yaml written in Go.
+ pkgver = r3.6337f37
+ pkgrel = 1
+ url = https://github.com/brancz/gojsontoyaml
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/brancz/gojsontoyaml.git
+ md5sums = SKIP
+
+pkgname = gojsontoyaml-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b4b7d01c1b0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*.tar.xz
+/*.tar.gz
+/pkg
+/src
+/gojsontoyaml
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aea0666c271
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jean-Francois Chevrette <jfchevrette@gmail.com>
+_pkgname=gojsontoyaml
+pkgname=${_pkgname}-git
+pkgver=r3.6337f37
+pkgrel=1
+pkgdesc="Simple tool to convert json to yaml written in Go."
+url="https://github.com/brancz/gojsontoyaml"
+license=('MIT')
+arch=('i686' 'x86_64')
+optdepends=()
+makedepends=('git' 'go')
+source=("git+https://github.com/brancz/gojsontoyaml.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/src/github.com/brancz/gojsontoyaml"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ rm -rf "$srcdir/src"
+ mkdir -p "$srcdir/src/github.com/brancz"
+ mv -T "$srcdir/gojsontoyaml" "$srcdir/src/github.com/brancz/gojsontoyaml"
+}
+
+build() {
+ export GOPATH="$srcdir"
+ cd "$GOPATH/src/github.com/brancz/gojsontoyaml"
+ go build -o gojsontoyaml
+}
+
+package() {
+ install -Dm755 "$GOPATH/src/github.com/brancz/gojsontoyaml/gojsontoyaml" -t "$pkgdir/usr/bin"
+}