summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Prager2022-05-25 02:56:38 +0200
committerMichael Prager2022-05-25 02:56:38 +0200
commitbf735ccca5beb53010f1a3640e457baf0fa79a36 (patch)
tree4d3008f0faccae698c6651a1d9fdba4d53610925
parent12ae9488a742106faf0006d868777a9d972376ff (diff)
downloadaur-bf735ccca5beb53010f1a3640e457baf0fa79a36.tar.gz
added support for R as optional dependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--gcconfig.pri4
3 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd8953dc8fdb..05774f205dbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = golden-cheetah-git
pkgdesc = Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the computer of their choice, analyze it in whatever way they see fit, and share their methods of analysis with others.
pkgver = v3.6.RC1.r58.a5d64686d
- pkgrel = 1
+ pkgrel = 2
url = http://www.goldencheetah.org/
arch = i686
arch = x86_64
@@ -35,6 +35,7 @@ pkgbase = golden-cheetah-git
optdepends = libical
optdepends = libusb-compat
optdepends = libsamplerate
+ optdepends = r
conflicts = golden-cheetah-rc
conflicts = golden-cheetah-dev
conflicts = golden-cheetah
@@ -49,7 +50,7 @@ pkgbase = golden-cheetah-git
sha256sums = SKIP
sha256sums = 6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d
sha256sums = e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e
- sha256sums = 2959d5570f271feec4de6277fb45208d987d20645185adf069e189dd32ba66b0
+ sha256sums = 0cac4a391dc360df375329122a5835fd50b3808ca17451bf56c9221a2710abb4
sha256sums = 843d4edf5b49e7620f7dcb58de7fcb65b833e22a1a6273afafda821c3f44da3e
pkgname = golden-cheetah-git
diff --git a/PKGBUILD b/PKGBUILD
index 95154d7db2a1..71adda76d201 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Ammann Max <maximilian.ammann@googlemail.com>
pkgname=golden-cheetah-git
pkgver=v3.6.RC1.r58.a5d64686d
-pkgrel=1
+pkgrel=2
pkgdesc="Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the
computer of their choice, analyze it in whatever way they see fit, and share their methods of
analysis with others."
@@ -11,7 +11,7 @@ url="http://www.goldencheetah.org/"
license=('GPL')
makedepends=(bison flex 'gcc' 'make' 'qt5-tools' sip4 pkgconf)
depends=('qt5-base' 'qt5-svg' qt5-location qt5-declarative qt5-webchannel qt5-webengine qt5-sensors qt5-serialport qt5-webkit qt5-multimedia qt5-script qt5-connectivity qt5-charts vlc gsl)
-optdepends=('vlc' 'srmio' 'libftd2xx' 'libkml' 'libical' 'libusb-compat' 'libsamplerate')
+optdepends=('vlc' 'srmio' 'libftd2xx' 'libkml' 'libical' 'libusb-compat' 'libsamplerate' 'r')
options=('!strip' '!buildflags' 'staticlibs')
conflicts=('golden-cheetah-rc' 'golden-cheetah-dev' 'golden-cheetah')
source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git'
@@ -20,7 +20,7 @@ GoldenCheetah.desktop gc.png gcconfig.pri
sha256sums=('SKIP'
'6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d'
'e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e'
- '2959d5570f271feec4de6277fb45208d987d20645185adf069e189dd32ba66b0'
+ '0cac4a391dc360df375329122a5835fd50b3808ca17451bf56c9221a2710abb4'
'843d4edf5b49e7620f7dcb58de7fcb65b833e22a1a6273afafda821c3f44da3e')
pkgver() {
diff --git a/gcconfig.pri b/gcconfig.pri
index 5de9b0bfe2d8..50367e27732a 100644
--- a/gcconfig.pri
+++ b/gcconfig.pri
@@ -23,7 +23,9 @@ GSL_LIBS = -lgsl -lgslcblas -lm
# You will need R installed along with the Rcpp and RInside
# packages. There is an R script in the `util' directory that
# can be run to install these packages; see it for more info.
-#DEFINES += GC_WANT_R
+packagesExist(libR) {
+ DEFINES += GC_WANT_R
+}
# Uncomment below if you want Python charting / ML etc
# You will need Python Development tools installed