summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Ammann2015-12-21 18:19:53 +0100
committerMax Ammann2015-12-21 18:19:53 +0100
commitf23e2681837ba910d49c07cbf212da85e30067c5 (patch)
tree1409d80c459e566509bde95b9929052697ebc766
downloadaur-f23e2681837ba910d49c07cbf212da85e30067c5.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--GoldenCheetah.desktop9
-rw-r--r--PKGBUILD51
-rw-r--r--gc.pngbin0 -> 189440 bytes
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..058c30faadc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 17:17:59 UTC 2015
+pkgbase = golden-cheetah-git
+ pkgdesc = Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the computer of their choice, analyze it in whatever way they see fit, and share their methods of analysis with others.
+ pkgver = v3.3.DEV1.r319.2f91591
+ pkgrel = 1
+ url = http://www.goldencheetah.org/
+ arch = any
+ license = GPL
+ makedepends = bison
+ makedepends = flex
+ makedepends = gcc
+ makedepends = make
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-location
+ depends = qt5-declarative
+ depends = qt5-webchannel
+ depends = qt5-sensors
+ depends = qt5-serialport
+ depends = qt5-webkit
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git
+ source = GoldenCheetah.desktop
+ source = gc.png
+ md5sums = SKIP
+ md5sums = af5e5a4376ee82ccfb69aa455b35a2d9
+ md5sums = e1fb382b4a7316da1ffd435e45e50c4a
+
+pkgname = golden-cheetah-git
+
diff --git a/GoldenCheetah.desktop b/GoldenCheetah.desktop
new file mode 100644
index 000000000000..50acd7320045
--- /dev/null
+++ b/GoldenCheetah.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=3.3.0
+Type=Application
+Name=GoldenCheetah
+Comment=Cycling Power Analysis Software.
+TryExec=/usr/bin/GoldenCheetah
+Exec=GoldenCheetah
+Icon=/usr/share/pixmaps/gc.png
+Keywords=Cycling;Training;Bike;Ride
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7f1c82d7562
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
+pkgname=golden-cheetah-git
+pkgver=v3.3.DEV1.r319.2f91591
+pkgrel=1
+pkgdesc="Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the
+computer of their choice, analyze it in whatever way they see fit, and share their methods of
+analysis with others."
+arch=('any')
+url="http://www.goldencheetah.org/"
+license=('GPL')
+makedepends=(bison flex 'gcc' 'make' 'qt5-tools')
+depends=('qt5-base' 'qt5-svg' qt5-location qt5-declarative qt5-webchannel qt5-sensors qt5-serialport qt5-webkit)
+options=('!strip' '!buildflags' 'staticlibs')
+source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git'
+GoldenCheetah.desktop gc.png)
+md5sums=('SKIP' af5e5a4376ee82ccfb69aa455b35a2d9 e1fb382b4a7316da1ffd435e45e50c4a)
+
+pkgver() {
+ cd "${srcdir}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${srcdir}/golden-cheetah/"
+
+ cd "qwt/"
+ cp qwtconfig.pri.in qwtconfig.pri
+ qmake-qt5
+ make -j8
+
+ cd "../kqoauth/"
+ qmake-qt5
+ make -j8
+
+ cd "../src/"
+ cp gcconfig.pri.in gcconfig.pri
+ qmake-qt5 QMAKE_LRELEASE=/usr/bin/lrelease-qt5
+ make -j8
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ cp "${srcdir}/golden-cheetah/src/GoldenCheetah" "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/lib/udev/rules.d/"
+ cp "${srcdir}/golden-cheetah/src/linux/51-garmin-usb.rules" "$pkgdir/usr/lib/udev/rules.d/"
+ chmod a+r "$pkgdir/usr/lib/udev/rules.d/51-garmin-usb.rules"
+ mkdir -p "$pkgdir/usr/share/applications/"
+ cp "${srcdir}/GoldenCheetah.desktop" "$pkgdir/usr/share/applications/"
+ mkdir -p "$pkgdir/usr/share/pixmaps/"
+ cp "${srcdir}/gc.png" "$pkgdir/usr/share/pixmaps/"
+}
diff --git a/gc.png b/gc.png
new file mode 100644
index 000000000000..386dfe99f482
--- /dev/null
+++ b/gc.png
Binary files differ