summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Ammann2021-06-06 21:04:29 +0200
committerMaximilian Ammann2021-06-06 21:04:29 +0200
commitf7f3e0532d59596effabdad86c92c6b4239da70b (patch)
tree5d72ef8b1b3d013693ecee935cb4f8dfd1c69c39
parent5d68ddac9fb16abe0160404f17bee7991b92da90 (diff)
downloadaur-f7f3e0532d59596effabdad86c92c6b4239da70b.tar.gz
Remove patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--add-missing-include-limits-for-std-numeric_limits.patch24
3 files changed, 4 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7adca106712..a6191f302cac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = golden-cheetah-git
pkgdesc = Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the computer of their choice, analyze it in whatever way they see fit, and share their methods of analysis with others.
pkgver = v3.6.DEV2101.r155.a5043d1b5
- pkgrel = 1
+ pkgrel = 2
url = http://www.goldencheetah.org/
arch = i686
arch = x86_64
@@ -46,12 +46,10 @@ pkgbase = golden-cheetah-git
source = gc.png
source = gcconfig.pri
source = https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch
- source = add-missing-include-limits-for-std-numeric_limits.patch
sha256sums = SKIP
sha256sums = 6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d
sha256sums = e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e
sha256sums = 2959d5570f271feec4de6277fb45208d987d20645185adf069e189dd32ba66b0
sha256sums = b98d4667711d1af37d439619de576352dc06321340da0834723cb7f258fdcab3
- sha256sums = fa9a6b200efaeda0a4cda31782e5c4d4bd96ba919b2c07e4ace81a61b0cc054a
pkgname = golden-cheetah-git
diff --git a/PKGBUILD b/PKGBUILD
index 74e6d4738fad..8a7173c44a18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
pkgname=golden-cheetah-git
pkgver=v3.6.DEV2101.r155.a5043d1b5
-pkgrel=1
+pkgrel=2
pkgdesc="Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the
computer of their choice, analyze it in whatever way they see fit, and share their methods of
analysis with others."
@@ -15,13 +15,12 @@ options=('!strip' '!buildflags' 'staticlibs')
conflicts=('golden-cheetah-rc' 'golden-cheetah-dev' 'golden-cheetah')
source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git'
GoldenCheetah.desktop gc.png gcconfig.pri
-'https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch' add-missing-include-limits-for-std-numeric_limits.patch)
+'https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch')
sha256sums=('SKIP'
'6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d'
'e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e'
'2959d5570f271feec4de6277fb45208d987d20645185adf069e189dd32ba66b0'
- 'b98d4667711d1af37d439619de576352dc06321340da0834723cb7f258fdcab3'
- 'fa9a6b200efaeda0a4cda31782e5c4d4bd96ba919b2c07e4ace81a61b0cc054a')
+ 'b98d4667711d1af37d439619de576352dc06321340da0834723cb7f258fdcab3')
pkgver() {
cd "${srcdir}/golden-cheetah"
@@ -31,7 +30,6 @@ pkgver() {
prepare() {
cd "${srcdir}/golden-cheetah/"
patch --forward --strip=1 --input="${srcdir}/3628.patch"
- patch --forward --strip=1 --input="${srcdir}/add-missing-include-limits-for-std-numeric_limits.patch"
}
build() {
diff --git a/add-missing-include-limits-for-std-numeric_limits.patch b/add-missing-include-limits-for-std-numeric_limits.patch
deleted file mode 100644
index c8a1b604e3c6..000000000000
--- a/add-missing-include-limits-for-std-numeric_limits.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From c2ce52367b265f9e7b259457c7fd164e14ffb9e3 Mon Sep 17 00:00:00 2001
-From: oxidative
-Date: Thu, 3 Jun 2021 02:09:54 +0200
-Subject: [PATCH] added missing include <limits> for std::numeric_limits
-
----
- src/Metrics/BlinnSolver.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/Metrics/BlinnSolver.cpp b/src/Metrics/BlinnSolver.cpp
-index 59f5e5bf9..b424d4687 100644
---- a/src/Metrics/BlinnSolver.cpp
-+++ b/src/Metrics/BlinnSolver.cpp
-@@ -18,6 +18,7 @@
-
- #include <cmath>
- #include <algorithm>
-+#include <limits>
- #include "BlinnSolver.h"
-
- int GetExponent(double a) {
---
-2.31.1
-