summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reuße2017-03-08 14:14:13 +0100
committerSebastian Reuße2017-03-08 14:14:13 +0100
commit15d4516a0e5c089f601d3fabd224712fff4707a2 (patch)
tree0dfd51b546db757f841a636a07f9ab7816ba9d3f
downloadaur-gommit-git.tar.gz
Init
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0b95378a001
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Mar 8 13:14:13 UTC 2017
+pkgbase = gommit-git
+ pkgdesc = Enforce git message commit consistency
+ pkgver = 2.0.0.r15.g522ce30
+ pkgrel = 1
+ url = https://github.com/antham/gommit
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = git
+ makedepends = go
+ depends = glibc
+ provides = gommit
+ conflicts = gommit
+ source = git+https://github.com/antham/gommit
+ md5sums = SKIP
+
+pkgname = gommit-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..468cd87d3ce8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d1d13aa4d93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+pkgname=gommit-git
+_gitname=gommit
+pkgver=2.0.0.r15.g522ce30
+pkgrel=1
+pkgdesc="Enforce git message commit consistency"
+arch=(x86_64 i686)
+url=https://github.com/antham/gommit
+license=(Apache)
+makedepends=(git go)
+depends=(glibc)
+provides=(gommit)
+conflicts=(gommit)
+source=(git+https://github.com/antham/gommit)
+md5sums=(SKIP)
+
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ export GOPATH="$srcdir/gopath"
+ [[ -d "$GOPATH" ]] || mkdir "$srcdir"/gopath
+ go get -d
+ # go build complains because we already have a directory
+ # with the output binary name, so use another name instead.
+ go build -o gommit.bin
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm755 gommit.bin "$pkgdir/usr/bin/gommit"
+}