summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Kuza2016-05-15 15:53:51 -0400
committerLuke Kuza2016-05-15 15:53:51 -0400
commit5ab63a97c223fe87303b2040bf857e43cb324e9b (patch)
tree827e0813f6bcd6078931967bfc7e708f7b7b5fc7
downloadaur-goofys.tar.gz
Initial PKGBUILD commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..063c5830e863
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = goofys
+ pkgdesc = Goofys is a high performance Amazon S3 backend filey-system interface
+ pkgver = 0.0.5.15.gbf6e5f8
+ pkgrel = 1
+ url = https://github.com/kahing/goofys/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = Apache
+ makedepends = git
+ makedepends = go
+ makedepends = fuse
+
+pkgname = goofys
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c0d194e4390
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luke Kuza <luke.kuza@gmail.com>
+
+pkgname=('goofys')
+pkgver=0.0.5.15.gbf6e5f8
+pkgrel=1
+pkgdesc="Goofys is a high performance Amazon S3 backend filey-system
+interface"
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url="https://github.com/kahing/goofys/"
+license=('Apache')
+makedepends=("git" "go" "fuse")
+
+prepare () {
+ GOPATH="$srcdir" go get github.com/kahing/goofys
+}
+
+pkgver () {
+ cd $srcdir/src/github.com/kahing/goofys
+ pkgv1="$(echo "$(git describe --tags)" | sed -e 's/\-/./g')"
+ echo "$(echo $pkgv1 | cut -c 2-)"
+}
+
+build() {
+ GOPATH="$srcdir" go install github.com/kahing/goofys
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin/
+ cp $srcdir/bin/goofys $pkgdir/usr/bin
+}