aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Ronecker2019-03-23 19:00:07 +0100
committerPascal Ronecker2019-03-23 19:00:07 +0100
commit45c09d409903236de6edcfe5da7a43fdacc4050d (patch)
treed692c671f158eff208aaf60845e554878b50d7fa
parent663e379a4eb90cd4cde3cb9d91fbbd0385251c22 (diff)
downloadaur-45c09d409903236de6edcfe5da7a43fdacc4050d.tar.gz
Electron beta included, source repo forked, fixes search issue
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD46
-rw-r--r--README.md5
-rw-r--r--chat-favicon-new-non-notif-256dp.pngbin41149 -> 0 bytes
-rw-r--r--chat-favicon-no-new-256dp.pngbin25998 -> 0 bytes
-rw-r--r--google-chat-linux.desktop9
-rwxr-xr-xgoogle-chat-linux.sh4
-rw-r--r--package.json16
9 files changed, 28 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a707830f436f..80c6ba3b1701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,15 @@
pkgbase = google-chat-linux-git
- pkgdesc = Unofficial electron-based desktop client for Google Chat
- pkgver = r19.17e08b2
+ pkgdesc = Unofficial electron-based desktop client for Google Chat, electron included
+ pkgver = r20.3b852b3
pkgrel = 1
- url = https://github.com/antoniofruci/google-chat-linux.git
+ url = https://github.com/squalou/google-chat-linux.git
arch = x86_64
arch = i686
license = WTFPL
makedepends = nodejs
makedepends = npm
- depends = electron>=1.8.4
- source = google-chat-linux::git+https://github.com/antoniofruci/google-chat-linux.git#branch=master
- source = google-chat-linux.desktop
- source = google-chat-linux.sh
- source = package.json
- source = chat-favicon-no-new-256dp.png
+ source = google-chat-linux-git::git+https://github.com/squalou/google-chat-linux.git#branch=master
sha256sums = SKIP
- sha256sums = e65b8b9b0556dded2521aa12b6d8e87c59f08a79b9e8cbee4273a7a659f72a6a
- sha256sums = d23052d27c870090987d1844e7c82bc42b878afa42c8af9a363d8414560ea34d
- sha256sums = 25b73ffc5ea40317faffaa277243617b1a2daed5bec7ddfb39e31274c5a88a79
- sha256sums = 573cfc3e46a33c24b1caeb324d83e9557bf982326f0e63efc2d0b01f491fa5dc
pkgname = google-chat-linux-git
diff --git a/.gitignore b/.gitignore
index 5383e9049d57..8702e2f28e98 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
src
pkg
*.xz
+google-chat-linux-git
google-chat-linux
updateSRCINFO.sh
diff --git a/PKGBUILD b/PKGBUILD
index cbc1edb476f4..b6b4cb096a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,47 @@
# Maintainer: Squalou <squalou.jenkins [at] gmail [dot] com>
pkgname=google-chat-linux-git
-pkgver=r19.17e08b2
+pkgver=r20.3b852b3
pkgrel=1
-pkgdesc="Unofficial electron-based desktop client for Google Chat"
+pkgdesc="Unofficial electron-based desktop client for Google Chat, electron included"
arch=('x86_64' 'i686')
-url="https://github.com/antoniofruci/google-chat-linux.git"
+url="https://github.com/squalou/google-chat-linux.git"
+electron_version='electron@v5.0.0-beta.6'
license=('WTFPL')
-depends=('electron>=1.8.4')
makedepends=('nodejs' 'npm')
[[ $CARCH == 'x86_64' ]] && _arch='x64' || _arch='ia32'
-source=("${pkgname%-git}::git+${url}#branch=master"
- "${pkgname%-git}.desktop"
- "${pkgname%-git}.sh"
- "package.json"
- "chat-favicon-no-new-256dp.png")
+source=("${pkgname%}::git+${url}#branch=master")
-sha256sums=('SKIP'
- 'e65b8b9b0556dded2521aa12b6d8e87c59f08a79b9e8cbee4273a7a659f72a6a'
- 'd23052d27c870090987d1844e7c82bc42b878afa42c8af9a363d8414560ea34d'
- '25b73ffc5ea40317faffaa277243617b1a2daed5bec7ddfb39e31274c5a88a79'
- '573cfc3e46a33c24b1caeb324d83e9557bf982326f0e63efc2d0b01f491fa5dc')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname}"
( set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #need to tweak numbering since fork, add 7 commits offset
+ ncom=$(git rev-list --count HEAD)
+ rev=$((ncom+7))
+ printf "r%s.%s" "$rev" "$(git rev-parse --short HEAD)"
)
}
build() {
- cp "$srcdir/package.json" "$srcdir/${pkgname%-git}/"
- cp "$srcdir/chat-favicon-no-new-256dp.png" "$srcdir/${pkgname%-git}/assets/icon/icon.png"
- cp "$srcdir/chat-favicon-no-new-256dp.png" "$srcdir/${pkgname%-git}/assets/icon/icon@2x.png"
- cp "$srcdir/chat-favicon-no-new-256dp.png" "$srcdir/${pkgname%-git}/assets/icon/"
- cd "$srcdir/${pkgname%-git}"
+ npm install --prefix $srcdir/${pkgname}/ ${electron_version}
+ cd "$srcdir/${pkgname}"
npm install --production=false
}
package() {
install -dm755 "${pkgdir}/usr/share"
- install -dm755 "${pkgdir}/usr/share/${pkgname%-git}"
install -dm755 "${pkgdir}/usr/share/pixmaps"
install -dm755 "${pkgdir}/usr/share/applications"
install -dm755 "${pkgdir}/usr/bin"
- install -Dm644 "${srcdir}/${pkgname%-git}/assets/icon/chat-favicon-no-new-256dp.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname%-git}.png"
- install -Dm644 "${srcdir}/${pkgname%-git}.desktop" "${pkgdir}/usr/share/applications/"
- install -Dm755 "${srcdir}/${pkgname%-git}.sh" "${pkgdir}/usr/bin/"
- rm -r "${srcdir}/${pkgname%-git}/.git"
- mv "${srcdir}/${pkgname%-git}" "${pkgdir}/usr/share/"
+ install -Dm644 "${srcdir}/${pkgname}/assets/icon/chat-favicon-no-new-256dp.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname%-git}.png"
+ install -Dm644 "${srcdir}/${pkgname}/${pkgname%-git}.desktop" "${pkgdir}/usr/share/applications/"
+ install -Dm755 "${srcdir}/${pkgname}/${pkgname%-git}.sh" "${pkgdir}/usr/bin/"
+ rm -r "${srcdir}/${pkgname}/.git"
+ mv "${srcdir}/${pkgname}" "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/share/${pkgname}" "${pkgdir}/usr/share/${pkgname%-git}"
}
diff --git a/README.md b/README.md
index fed8f4d633c9..47399d88cffb 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,9 @@
# google-chat-linux-git
-aur package for this upstream project : https://github.com/robyf/google-chat-linux
+aur package for this upstream project : https://github.com/squalou/google-chat-linux
I'm not the author of the app : praise **robyf** for his excellent work.
+I forked it, and now apckage it for AUR.
+
+This package includes electron runtime (5.0.0-beta6). This may change when beta version is no more required. (long story short : google chat web client inside electron 'search' function requires a recent version on chromium)
diff --git a/chat-favicon-new-non-notif-256dp.png b/chat-favicon-new-non-notif-256dp.png
deleted file mode 100644
index cf5f46ae3d2a..000000000000
--- a/chat-favicon-new-non-notif-256dp.png
+++ /dev/null
Binary files differ
diff --git a/chat-favicon-no-new-256dp.png b/chat-favicon-no-new-256dp.png
deleted file mode 100644
index 8f14198f98b1..000000000000
--- a/chat-favicon-no-new-256dp.png
+++ /dev/null
Binary files differ
diff --git a/google-chat-linux.desktop b/google-chat-linux.desktop
deleted file mode 100644
index a4a47d91cf26..000000000000
--- a/google-chat-linux.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Terminal=false
-Type=Application
-Name=Google Chat Linux
-Comment=Desktop client for Google Chat
-Exec=/usr/bin/google-chat-linux.sh
-Icon=google-chat-linux.png
-StartupWMClass=google-chat-linux
-Categories=Network;InstantMessaging;
diff --git a/google-chat-linux.sh b/google-chat-linux.sh
deleted file mode 100755
index a4015522133a..000000000000
--- a/google-chat-linux.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-cd /usr/share/google-chat-linux \
- && /usr/bin/electron .
-
diff --git a/package.json b/package.json
deleted file mode 100644
index 941294721460..000000000000
--- a/package.json
+++ /dev/null
@@ -1,16 +0,0 @@
-{
- "name": "google-chat-linux",
- "version": "0.0.4-1",
- "description": "Google Hangouts Chat unofficial linux app",
- "main": "main.js",
- "scripts": {
- "start": "electron ."
- },
- "repository": "TODO",
- "author": "Roberto Fasciolo <rob@robyf.net> (https://www.robyf.net/)",
- "license": "WTFPL",
- "dependencies": {
- "electron-context-menu": "^0.9.1",
- "electron-localshortcut": "^3.1.0"
- }
-}