summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Kubica2016-10-06 22:10:51 +0300
committerAlex Kubica2016-10-06 22:10:51 +0300
commit7a71785b12b66f08cfeb50d32681ac2b304a54f2 (patch)
treee7147ca4e7c257806416dc812dbef99d51fce405
parentc34cda533dea95e73209d65bdff9394eff197c09 (diff)
downloadaur-7a71785b12b66f08cfeb50d32681ac2b304a54f2.tar.gz
improve pkgbuild and add license file
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD76
2 files changed, 53 insertions, 31 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ea7dedbb6d10
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+GoPanda2 belongs to Pandanet Inc, all rights reserved.
+
+The software is delivered "as is" and we take no responsibility for
+any problems that arise from usage.
+
+GoPanda2 may be redistributed by third parties only when free of
+charge or advertisements and without modifications to the
+included source code or resource files.
diff --git a/PKGBUILD b/PKGBUILD
index 3d55b21d9a3d..8ff2cd870290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,53 @@
# Maintainer: Sébastien Feugère <smonff@riseup.net>
+# Contributor: Alex Kubica <alexkubicail@gmail.com>
pkgname=gopanda
pkgver=2
-pkgrel=2
-pkgdesc="GoPanda 2 is a modern client to Pandanet that runs in the browser."
-arch=('x86_64')
+pkgrel=3
+pkgdesc="Client for the Pandanet-IGS go Server"
+arch=('i686' 'x86_64')
url="http://pandanet-igs.com/communities/$pkgname$pkgversion"
license=('custom')
-depends=('xdg-utils')
-# TODO multi arch script
-source=("http://pandanet-igs.com/$pkgname$pkgver/installer/stable/linux-64/$pkgname$pkgver-linux-64.tar.gz")
-md5sums=('d1fcd13d8de0f2c0331ee0a9cb58a58a')
-# Generated using makepkg -g
-
-
-# build() {
-# cd "$srcdir/GoPanda$pkgver"
-# ./configure --prefix=/usr
-# make
-# }
+depends=('libnotify'
+ 'alsa-lib'
+ 'libxtst'
+ 'gtk2'
+ 'gconf'
+ 'nss')
+options=(!strip)
+source=(LICENSE)
+source_i686=("http://pandanet-igs.com/$pkgname$pkgver/installer/stable/linux-32/$pkgname$pkgver-linux-32.tar.gz")
+source_x86_64=("http://pandanet-igs.com/$pkgname$pkgver/installer/stable/linux-64/$pkgname$pkgver-linux-64.tar.gz")
+md5sums=('c5951d02adb28f6b333d913ae2f92df0')
+md5sums_i686=('170e380003a712267e3e85c0fe38011a')
+md5sums_x86_64=('d1fcd13d8de0f2c0331ee0a9cb58a58a')
+_DEST="/usr/share/$pkgname"
+_CLIENT="GoPanda2"
+_DESKTOP="/usr/share/applications/${_CLIENT}.desktop"
+_ICON="/usr/share/pixmaps/${_CLIENT}.png"
package() {
- cd "GoPanda2"
- make DESTDIR="$pkgdir/" install
-
- # Run the installation script
- sh "$srcdir/GoPanda2/install.sh"
-
- # set the installation path...
- install_path="$HOME/.local/bin/GoPanda2"
-
- # Write the license to the installation path
- license_content="GoPanda2 belongs to Pandanet Inc, all rights reserved.\n\nThe software is delivered \"as is\" and we take no responsibility for\nany problems that arise from usage.\n\nGoPanda2 may be redistributed by third parties only when free of\ncharge or advertisements and without modifications to the\nincluded source code or resource files."
-
-
- echo -e $license_content
-
- sudo ln -s "$install_path" /usr/bin/gopanda2
+ # Copy license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "$srcdir/${_CLIENT}"
+
+ # Program
+ install -dm755 "${pkgdir}${_DEST}"
+ install -m755 "${_CLIENT}" "${pkgdir}${_DEST}"
+ install -m644 "nw.pak" "${pkgdir}${_DEST}"
+ install -m644 "libffmpegsumo.so" "${pkgdir}${_DEST}"
+ install -m644 "icudtl.dat" "${pkgdir}${_DEST}"
+
+ # Link to program
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "${_DEST}/${_CLIENT}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Icon
+ install -Dm644 "${_CLIENT}.png" "${pkgdir}${_ICON}"
+
+ # Desktop file
+ install -Dm644 "${_CLIENT}.orig" "${pkgdir}${_DESKTOP}"
+ echo "Exec=${_DEST}/${_CLIENT}" >> "${pkgdir}${_DESKTOP}"
+ echo "Icon=${_ICON}" >> "${pkgdir}${_DESKTOP}"
+ echo "MimeType=application/x-go-sgf;application/x-go-ugf;application/x-go-ugi;" >> "${pkgdir}${_DESKTOP}"
}