summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Bassi2019-02-23 15:26:38 -0800
committerCaleb Bassi2019-02-23 15:26:38 -0800
commit982dc85493d93d2b980e694a3109622cb8a69e9b (patch)
tree1c7d23997a79bbb003a5ffca13f890acb558c2a8
parent64b43660e0adde08fc517f6bb1cd3040f0b9b962 (diff)
downloadaur-982dc85493d93d2b980e694a3109622cb8a69e9b.tar.gz
Refactor pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad8e6d829846..504062f0512e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gotop-bin
pkgdesc = A terminal based graphical activity monitor inspired by gtop and vtop
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cjbassi/gotop
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 507d747a97cd..71a0c8658157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Caleb Bassi <calebjbassi@gmail.com>
pkgname=gotop-bin
+_pkgname=${pkgname%-bin}
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A terminal based graphical activity monitor inspired by gtop and vtop"
arch=("x86_64" "i686")
-url="https://github.com/cjbassi/gotop"
+url="https://github.com/cjbassi/${_pkgname}"
license=("AGPL3")
-provides=("gotop")
-conflicts=("gotop")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
case "$CARCH" in
x86_64)
@@ -19,9 +20,9 @@ case "$CARCH" in
;;
esac
-source=("https://github.com/cjbassi/gotop/releases/download/$pkgver/gotop_${pkgver}_linux_$_arch.tgz")
+source=("${url}/releases/download/${pkgver}/${_pkgname}_${pkgver}_linux_${_arch}.tgz")
sha256sums=("7fd4c34398a63dcf3189db91ba2dbe9c1d8b96a0a04814ef56b8e764b145e608")
package() {
- install -Dm755 "$srcdir/gotop" "$pkgdir/usr/bin/gotop"
+ install -Dm755 "${srcdir}/gotop" "${pkgdir}/usr/bin/gotop"
}