summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2022-12-19 21:16:59 +0300
committerYigit Sever2022-12-19 21:16:59 +0300
commit772f3c695aace8178266f0cdd0b31b30cfff11b4 (patch)
tree9cc9599d2e24af383a049634ea7dc84b93189318
parent904ab220ae5765d1aec333f90e183a91a5e488ab (diff)
downloadaur-gourmand.tar.gz
gourmand: Use sqlalchemy1.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37b646042445..de3e92cd58aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gourmand
pkgdesc = A recipe manager for desktop that can import recipes
pkgver = 1.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/GourmandRecipeManager/gourmand
arch = any
license = GPL
@@ -12,7 +12,7 @@ pkgbase = gourmand
depends = python-pyenchant
depends = gst-python
depends = python-pillow
- depends = python-sqlalchemy
+ depends = python-sqlalchemy1.3
depends = python-lxml
depends = python-cairo
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index 92e52c9a2c9a..610fd628968f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
pkgname='gourmand'
pkgver=1.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A recipe manager for desktop that can import recipes"
arch=('any')
url="https://github.com/GourmandRecipeManager/gourmand"
license=('GPL')
-depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
+depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy1.3' 'python-lxml' 'python-cairo' 'python-requests')
makedepends=('python-pip' 'gendesk')
-checkdepends=()
optdepends=(
'python-beautifulsoup4: Webpage import plugin'
'python-scrape-schema-recipe: Webpage import plugin'
@@ -31,7 +30,6 @@ prepare() {
}
package() {
- # https://wiki.archlinux.org/title/Python_package_guidelines#pip
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}