summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvcalv2022-02-02 18:24:33 -0400
committervcalv2022-02-02 18:24:33 -0400
commit4c13826600ee73867a53a120b7417ab8cef80e74 (patch)
treeb0d462d26eacb733cbc0d82c81676db0636815d6
downloadaur-4c13826600ee73867a53a120b7417ab8cef80e74.tar.gz
new package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27c975103d5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gourou-bin
+ pkgdesc = Download and decrypt adobe encrypted (acsm) pdf and epub files
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://indefero.soutade.fr/p/libgourou
+ arch = x86_64
+ license = LGPL3
+ depends = glibc
+ depends = gcc-libs
+ depends = qt5-base
+ depends = zlib
+ depends = libzip
+ depends = openssl
+ options = !strip
+ source = https://indefero.soutade.fr/p/libgourou/downloads/get/libgourou_utils_0.5.1.tgz
+ md5sums = 3500e207aabfe591cbfde15e818d7ffe
+
+pkgname = gourou-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..780f48d1b291
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: VCalV
+_pkgname=gourou
+pkgname="${_pkgname}-bin"
+__pkgname="lib${_pkgname}"
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="Download and decrypt adobe encrypted (acsm) pdf and epub files"
+arch=('x86_64')
+license=('LGPL3')
+url="https://indefero.soutade.fr/p/libgourou"
+depends=(glibc gcc-libs qt5-base zlib libzip openssl)
+options=(!strip)
+source=("https://indefero.soutade.fr/p/${__pkgname}/downloads/get/${__pkgname}_utils_${pkgver}.tgz")
+md5sums=(3500e207aabfe591cbfde15e818d7ffe)
+
+package() {
+ cd "${srcdir}/${__pkgname}_utils_${pkgver}"
+
+ install -d $pkgdir/{usr/bin/,usr/lib/}
+ cp -a --no-preserve=ownership {acsmdownloader,adept_activate,adept_remove} $pkgdir/usr/bin
+ cp -a --no-preserve=ownership *.so $pkgdir/usr/lib
+}