summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvcalv2023-03-02 23:59:17 -0500
committervcalv2023-03-02 23:59:17 -0500
commit73661d165dceeb66c80409e9d69932cdcf517a8f (patch)
treedccc1464fcf44ef4a310ded2db1fda4d8c1fff1d
parentf29d28a5119ef31aab6945fddbfd6d6a336f37e7 (diff)
downloadaur-73661d165dceeb66c80409e9d69932cdcf517a8f.tar.gz
version bump and fix zlib versioning problem
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6b3a512f4c4..44b20bdc4e35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
_pkgname=gourou
pkgname="${_pkgname}-bin"
__pkgname="lib${_pkgname}"
-pkgver=0.8
+pkgver=0.8.1
pkgrel=1
pkgdesc="Download and decrypt adobe encrypted (acsm) pdf and epub files"
arch=('x86_64')
license=('LGPL3')
url="https://indefero.soutade.fr/p/libgourou"
-depends=(glibc gcc-libs zlib libzip openssl-3.0)
+depends=(glibc gcc-libs zlib libzip openssl)
conflicts=(gourou gourou-git)
options=(!strip)
source=("https://indefero.soutade.fr/p/${__pkgname}/downloads/get/${__pkgname}_utils_${pkgver}.tgz")
-sha512sums=(9ae25d14d209909c2eac4415fd72eb8612509c3167529bbb03f4e12ae3948f364bc387c87e75f861d929eb6664ff67ed3096d0c8316ef75bbcb58c787bb8c4e3)
+sha512sums=(ee5e2ffd298fd38757f6a060fc2d697222d50834cdb0e19837fd036ce08eb5a1fa57cc201e11237e18b0b8f2714f7afb0e5d21ca97497aa48e6e90e551ffe4b3)
package() {
cd "${srcdir}/${__pkgname}_utils_${pkgver}"
install -d $pkgdir/{usr/bin/,usr/lib/}
- cp -a --no-preserve=ownership {acsmdownloader,adept_activate,adept_remove} $pkgdir/usr/bin
+ cp -a --no-preserve=ownership {acsmdownloader,adept_activate,adept_remove} "$pkgdir"/usr/bin
+ # super ugly but it works!
+ sed -i 's/libzip\.so\.4/libzip.so.5/' "$pkgdir"/usr/bin/*
cp -a --no-preserve=ownership *.so $pkgdir/usr/lib
}