summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-11-09 09:08:43 -0700
committerMark Wagie2020-11-09 09:08:43 -0700
commitead65d8dd68f8154d939a10aed11000796513f07 (patch)
tree11d55be160f3c0a77bf65190b942a7c2eab67a9b
parent32231624fe4cf0a29c7527eed738f698f7688935 (diff)
downloadaur-ead65d8dd68f8154d939a10aed11000796513f07.tar.gz
Qt5 test
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD11
3 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 559fbac2c983..6a75230251a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = goverlay-git
pkgdesc = A GUI to help manage Vulkan/OpenGL overlays
- pkgver = 0.4.r2.gcdf6db7
+ pkgver = 0.4.r11.gba8c508
pkgrel = 1
url = https://github.com/benjamimgois/goverlay
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = goverlay-git
checkdepends = appstream
makedepends = git
makedepends = lazarus
- depends = gtk2
+ depends = qt5pas
optdepends = mangohud: Configure MangoHUD
optdepends = vkbasalt: Configure vkBasalt
optdepends = mesa-demos: OpenGL preview
@@ -17,7 +17,7 @@ pkgbase = goverlay-git
optdepends = replay-sorcery: Instant replay solution
provides = goverlay
conflicts = goverlay
- source = git+https://github.com/benjamimgois/goverlay.git
+ source = git+https://github.com/benjamimgois/goverlay.git#branch=qt5
sha256sums = SKIP
pkgname = goverlay-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 5feba6489733..9b31131b2a64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=goverlay-git
-pkgver=0.4.r2.gcdf6db7
+pkgver=0.4.r11.gba8c508
pkgrel=1
pkgdesc="A GUI to help manage Vulkan/OpenGL overlays"
arch=('x86_64')
url="https://github.com/benjamimgois/goverlay"
license=('GPL3')
-depends=('gtk2')
+depends=('qt5pas')
makedepends=('git' 'lazarus')
checkdepends=('appstream')
optdepends=('mangohud: Configure MangoHUD'
@@ -17,7 +17,7 @@ optdepends=('mangohud: Configure MangoHUD'
'replay-sorcery: Instant replay solution')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/benjamimgois/goverlay.git')
+source=('git+https://github.com/benjamimgois/goverlay.git#branch=qt5')
sha256sums=('SKIP')
pkgver() {
@@ -25,6 +25,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ sed -i 's/lazbuild -B goverlay.lpi/lazbuild -B goverlay.lpi --ws=qt5/g' Makefile
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
make LAZBUILDOPTS=--lazarusdir=/usr/lib/lazarus