summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-04-16 20:32:08 +0300
committerIgor Dyatlov2021-04-16 20:32:08 +0300
commitbf7f36cfacc74d61ab18553eeb876fbc9119b374 (patch)
tree5132c014c1f5823236f7eca21589542ac7ff8699
downloadaur-gpbkdf2-bin.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c01717436f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gpbkdf2-bin
+ pkgdesc = PBKDF2 key encoder for use in shell. Single, tiny binary. Written in Go
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/riotkit-org/gpbkdf2
+ arch = x86_64
+ arch = armv7h
+ license = LGPL3
+ source_x86_64 = gpbkdf2::https://github.com/riotkit-org/gpbkdf2/releases/download/v1.0/gpbkdf2
+ sha256sums_x86_64 = 97f8acfbbf3ab465df4faf3c752602aa5e91f1ae0040032bf9ab106dbc88398d
+ source_armv7h = gpbkdf2_armv7::https://github.com/riotkit-org/gpbkdf2/releases/download/v1.0/gpbkdf2_armv7
+ sha256sums_armv7h = 81815cffc72e5c3756c1679d986aff5f2c4f1eea8170787b89759ed5b6e5e56e
+
+pkgname = gpbkdf2-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab7540c57c98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+# Contributor: RiotKit <youremail@domain.com>
+
+pkgname=gpbkdf2-bin
+_pkgname=gpbkdf2
+pkgver=1.0
+pkgrel=1
+pkgdesc="PBKDF2 key encoder for use in shell. Single, tiny binary. Written in Go"
+arch=('x86_64' 'armv7h')
+url="https://github.com/riotkit-org/gpbkdf2"
+license=('LGPL3')
+source_x86_64=("gpbkdf2::${url}/releases/download/v${pkgver}/gpbkdf2")
+source_armv7h=("gpbkdf2_armv7::${url}/releases/download/v${pkgver}/gpbkdf2_armv7")
+noextract=(${source[@]%%::*})
+sha256sums_x86_64=('97f8acfbbf3ab465df4faf3c752602aa5e91f1ae0040032bf9ab106dbc88398d')
+sha256sums_armv7h=('81815cffc72e5c3756c1679d986aff5f2c4f1eea8170787b89759ed5b6e5e56e')
+
+package() {
+ if [[ $CARCH == 'x86_64' ]]; then
+ install -Dm755 "$srcdir/gpbkdf2" "$pkgdir/usr/bin/$_pkgname"
+ elif [[ $CARCH == 'armv7h' ]]; then
+ install -Dm755 "$srcdir/gpbkdf2_armv7" "$pkgdir/usr/bin/$_pkgname"
+ fi
+} \ No newline at end of file