summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeaDDooMER2015-10-08 23:39:04 +0300
committerDeaDDooMER2015-10-08 23:39:04 +0300
commitf6ed6583958e1b9f2dc5d9de0f7dccbe1c8fed55 (patch)
tree2291ec04b71a125763b6ba8197bd4b86b61d3910
downloadaur-gpcp-patched-jvm.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rwxr-xr-xcprun3
-rwxr-xr-xj2cps3
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bd0885541c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gpcp-patched-jvm
+ pkgdesc = Gardens Point Component Pascal
+ pkgver = 1.3.18rc
+ pkgrel = 1
+ url = https://gpcp.codeplex.com
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = java-runtime
+ conflicts = gpcp-jvm
+ source = git+https://github.com/DeaDDooMER/gpcp-linux.git
+ source = cprun
+ source = j2cps
+ md5sums = SKIP
+ md5sums = 38aee573d8e2dc342f8bfab7abf0a9a2
+ md5sums = 6234ff1df2bdcf514caf0422ea3f10d9
+
+pkgname = gpcp-patched-jvm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d01413cb891
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: DeaDDooMER <deaddoomer@deadsoftware.ru>
+pkgname=gpcp-patched-jvm
+pkgver=1.3.18rc
+pkgrel=1
+pkgdesc="Gardens Point Component Pascal"
+url="https://gpcp.codeplex.com"
+arch=('any')
+license=('BSD')
+makedepends=('git')
+depends=('java-runtime')
+conflicts=('gpcp-jvm')
+source=("git+https://github.com/DeaDDooMER/gpcp-linux.git" "cprun" "j2cps")
+md5sums=('SKIP' '38aee573d8e2dc342f8bfab7abf0a9a2' '6234ff1df2bdcf514caf0422ea3f10d9')
+
+build() {
+ cd ${srcdir}/gpcp-linux
+ echo "Commit $(git describe --always)"
+}
+
+package() {
+ cd ${srcdir}/gpcp-linux
+
+ install -d $pkgdir/usr/share/java/gpcp-JVM
+ cp -R out/* $pkgdir/usr/share/java/gpcp-JVM
+ chmod -R 755 $pkgdir/usr/share/java/gpcp-JVM
+
+ install -Dm755 $srcdir/cprun $pkgdir/usr/bin/cprun
+ install -Dm755 $srcdir/j2cps $pkgdir/usr/bin/j2cps
+}
diff --git a/cprun b/cprun
new file mode 100755
index 000000000000..9b17ac194ea7
--- /dev/null
+++ b/cprun
@@ -0,0 +1,3 @@
+#!/bin/sh
+JRoot=/usr/share/java/gpcp-JVM
+java -DCPSYM=$CPSYM:$JRoot/libs:$JRoot/libs/JvmSystem -cp $JRoot CP.$1.$*
diff --git a/j2cps b/j2cps
new file mode 100755
index 000000000000..2f6d4020914a
--- /dev/null
+++ b/j2cps
@@ -0,0 +1,3 @@
+#!/bin/sh
+JRoot=/usr/share/java/gpcp-JVM
+java -DCPSYM=$CPSYM:$JRoot/libs:$JRoot/libs/JvmSystem -cp $JRoot J2CPS.J2CPS $*