summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-12 20:05:24 -0500
committerVincent Grande2021-01-12 20:05:24 -0500
commitdfabd38947d74bae081984ab18afc8d3d6c2a832 (patch)
treec646171947ef4e2b6b871d1c232b19dc4cd14b89
downloadaur-gpgme-minimal-git.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD76
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2adb6e1a76ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gpgme-minimal-git
+ pkgdesc = A C wrapper library for GnuPG
+ pkgver = 1.15.1
+ pkgrel = 1
+ url = https://www.gnupg.org/related_software/gpgme/
+ arch = x86_64
+ license = LGPL
+ makedepends = libgpg-error
+ makedepends = gnupg
+ makedepends = qt5-base
+ makedepends = python
+ makedepends = swig
+ source = git://git.gnupg.org/gpgme.git
+ sha256sums = SKIP
+
+pkgname = gpgme-minimal-git
+ depends = libgpg-error
+ depends = gnupg>=2
+ provides = libgpgme.so
+ provides = libgpgmepp.so
+ provides = gpgme
+ conflicts = gpgme
+ options = !emptydirs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0846b7ead48c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+
+pkgname=(gpgme-minimal-git)
+pkgver=1.15.1
+pkgrel=1
+_python_ver=3.9
+pkgdesc="A C wrapper library for GnuPG"
+arch=('x86_64')
+url='https://www.gnupg.org/related_software/gpgme/'
+license=('LGPL')
+makedepends=('libgpg-error' 'gnupg' 'qt5-base' 'python' 'swig')
+#validpgpkeys=('6DAA6E64A76D2840571B4902528897B826403ADA') # Werner Koch (dist signing 2020)
+source=(git://git.gnupg.org/gpgme.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gpgme
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd gpgme
+
+ export PYTHONHASHSEED=0
+
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --disable-fd-passing \
+ --disable-static \
+ --disable-gpgsm-test \
+ --disable-gpgconf-test \
+ --disable-gpg-test \
+ --disable-g13-test
+ make
+
+ # ensure reproducibility of .pyc files
+ touch -d @$SOURCE_DATE_EPOCH lang/python/version.py
+ touch -d @$SOURCE_DATE_EPOCH lang/python/python${_python_ver}-gpg/lib.linux-x86_64-${_python_ver}/gpg/gpgme.py
+
+ # .pyc files will be created if check() is used - generate them here
+
+}
+
+#check() {
+# cd gpgme
+
+ # this test fails with gnupg (FS#66572)
+# sed -i 's#"t-keylist-secret",##' tests/json/t-json.c
+
+# make check
+
+ # ensure reproducibilty whether test-suite is run or not
+# find . -name *.pyc -exec rm {} +
+#}
+
+package_gpgme-minimal-git() {
+ depends=('libgpg-error' 'gnupg>=2')
+ options=('!emptydirs')
+ provides=('libgpgme.so'
+ 'libgpgmepp.so'
+ 'gpgme')
+ conflicts=(gpgme)
+
+ cd gpgme
+
+ make DESTDIR="${pkgdir}" install
+
+ # split qgpgme
+ rm -r "${pkgdir}"/usr/include/{qgpgme,QGpgME}/
+ rm -r "${pkgdir}"/usr/lib/{cmake/QGpgme/,libqgpgme.*}
+ rm -r "${pkgdir}"/usr/lib/python*
+}