summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortest2023-03-29 12:45:37 +0800
committertest2023-03-29 12:45:37 +0800
commit6d6ef1a66fb7ea8d0d4c71d1dbcf35b89566d57f (patch)
tree593033e669433edf08a4edf91503eb5b787db7b1
parentd5ba303550088d0bba51209e068288c7d6e3ac64 (diff)
downloadaur-gpu-burn-git.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fcfcf8efe58..6ee4052667d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = gpu-burn-git
pkgdesc = Multi-GPU CUDA stress test
- pkgver = r50.1e9a84f
+ pkgver = r76.5f0a86c
pkgrel = 1
url = https://github.com/wilicc/gpu-burn
arch = x86_64
license = BSD
makedepends = git
- depends = nvidia
- depends = opencl-nvidia
+ depends = nvidia-utils
depends = cuda
provides = gpu-burn
conflicts = gpu_burn-git
diff --git a/PKGBUILD b/PKGBUILD
index e0c664fed0f7..9f90f892a544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: sparklespdx <josh.farwell@gmail.com>
pkgname="gpu-burn-git"
-pkgver="r50.1e9a84f"
+pkgver=r76.5f0a86c
pkgrel=1
pkgdesc="Multi-GPU CUDA stress test"
arch=("x86_64")
url="https://github.com/wilicc/gpu-burn"
license=("BSD")
makedepends=("git")
-depends=("nvidia" "opencl-nvidia" "cuda")
+depends=("nvidia-utils" "cuda")
provides=("gpu-burn")
conflicts=("gpu_burn-git" "gpu-burn")
replaces=("gpu_burn-git")
@@ -25,10 +25,10 @@ pkgver() {
}
prepare () {
- sed -i "s|CUDAPATH ?= /usr/local/cuda|CUDAPATH ?= /opt/cuda|g" "${pkgname}"/Makefile
+ sed -i "s|/usr/local/cuda|/opt/cuda|g" "${pkgname}"/Makefile
# Hax to make the program pick up compare.ptx in /usr/lib
- sed -i 's|const char \*kernelFile = "compare.ptx"|const char \*kernelFile = "/usr/lib/gpu_burn/compare.ptx"|g' "${pkgname}"/gpu_burn-drv.cpp
+ sed -i 's|"compare.ptx"|"/usr/lib/gpu_burn/compare.ptx"|g' "${pkgname}"/gpu_burn-drv.cpp
}
build () {