summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Heimbach2020-06-30 18:15:52 +0200
committerIngo Heimbach2020-06-30 18:15:52 +0200
commit9f42fc3560a8e69087a6ba2146d93919119ebb7f (patch)
treeab9af19836adeb5348a15ee28cbd9b07d8836983
parentb90aefeecff9e258c00052268f38591bbbad4ae4 (diff)
downloadaur-9f42fc3560a8e69087a6ba2146d93919119ebb7f.tar.gz
Add a fix for Qt 5.15
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--gr-framework-0.50.0.patch12
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03ea6485f6ca..096366ceb9ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gr-framework
pkgdesc = A universal framework for cross-platform visualization applications.
pkgver = 0.50.0
- pkgrel = 1
+ pkgrel = 2
url = https://gr-framework.org
arch = i686
arch = x86_64
@@ -28,7 +28,9 @@ pkgbase = gr-framework
depends = zlib
optdepends = ffmpeg: video support
source = https://github.com/sciapp/gr/archive/v0.50.0.tar.gz
+ source = gr-framework-0.50.0.patch
sha256sums = 59947975c364b8ce98940eee4cf98a665ede66083362e60f3e3520d9c7d8bc1e
+ sha256sums = d0a1153447977bca8a0336396b7b5dcfa3f04d65570a88f5a507af19f9ff1b98
pkgname = gr-framework
diff --git a/PKGBUILD b/PKGBUILD
index 05a84a349dcb..1770ffac31fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="gr-framework"
pkgver="0.50.0"
-pkgrel="1"
+pkgrel="2"
pkgdesc="A universal framework for cross-platform visualization applications."
arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
url="https://gr-framework.org"
@@ -12,11 +12,14 @@ depends=("bzip2" "cairo" "fontconfig" "freetype2" "ghostscript" "glfw-x11" \
"qhull" "qt5-base" "zlib")
makedepends=("cmake")
optdepends=("ffmpeg: video support")
-source=("https://github.com/sciapp/gr/archive/v${pkgver}.tar.gz")
-sha256sums=("59947975c364b8ce98940eee4cf98a665ede66083362e60f3e3520d9c7d8bc1e")
+source=("https://github.com/sciapp/gr/archive/v${pkgver}.tar.gz"
+ "${pkgname}-${pkgver}.patch")
+sha256sums=("59947975c364b8ce98940eee4cf98a665ede66083362e60f3e3520d9c7d8bc1e"
+ "d0a1153447977bca8a0336396b7b5dcfa3f04d65570a88f5a507af19f9ff1b98")
prepare() {
cd "${srcdir}/gr-${pkgver}" || return
+ patch -Np1 -i "${srcdir}/${pkgname}-${pkgver}.patch" && \
echo "${pkgver}" > version.txt
}
diff --git a/gr-framework-0.50.0.patch b/gr-framework-0.50.0.patch
new file mode 100644
index 000000000000..1039670004fa
--- /dev/null
+++ b/gr-framework-0.50.0.patch
@@ -0,0 +1,12 @@
+diff --git a/lib/gks/plugin/qt5plugin.cxx b/lib/gks/plugin/qt5plugin.cxx
+index de9cd3d2..301d7fb9 100644
+--- a/lib/gks/plugin/qt5plugin.cxx
++++ b/lib/gks/plugin/qt5plugin.cxx
+@@ -6,6 +6,7 @@
+
+ #include <QtWidgets/QWidget>
+ #include <QtGui/QPainter>
++#include <QtGui/QPainterPath>
+ #include <QtGui/QImage>
+ #include <QtGui/QGuiApplication>
+ #include <QtGui/QScreen>