summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Rooyakkers2018-06-21 20:37:01 -0400
committerLucas Rooyakkers2018-06-21 20:37:01 -0400
commitcc233ef4d2096e799e7821a49a4d7018b8effaeb (patch)
treec8c6a894d8999ab68c9a2f10fba50ecfa6f49d10
downloadaur-gr-ieee802-15-4.tar.gz
Intial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD37
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..939bb844c6d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gr-ieee802-15-4
+ pkgdesc = An 802.15.4 ZigBee transceiver for GNU Radio.
+ pkgver = v3.6.99.gc969b3f
+ pkgrel = 1
+ url = https://github.com/bastibl/gr-ieee802-15-4
+ arch = any
+ license = unknown
+ makedepends = cmake
+ makedepends = boost
+ depends = gnuradio
+ depends = swig
+ depends = log4cpp
+ depends = gr-foo
+ optdepends = python2-matplotlib: To run the GUI sample application
+ provides = gr-ieee802-15-4
+ source = git+https://github.com/bastibl/gr-ieee802-15-4
+ sha1sums = SKIP
+
+pkgname = gr-ieee802-15-4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a786c883ad4d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+gr-ieee802-15-4/
+pkg/
+*.pkg.tar.xz
+src/
+*.tar.gz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e1193a63b20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Mainintainer : Lucas Rooyakkers <lucas dot rooyakkers at queensu at ca>
+
+pkgname='gr-ieee802-15-4'
+pkgver=v3.6.99.gc969b3f
+pkgrel=1
+pkgdesc="An 802.15.4 ZigBee transceiver for GNU Radio."
+arch=('any')
+url="https://github.com/bastibl/gr-ieee802-15-4"
+license=('unknown')
+depends=('gnuradio' 'swig' 'log4cpp' 'gr-foo')
+optdepends=('python2-matplotlib: To run the GUI sample application')
+makedepends=('cmake' 'boost')
+provides=('gr-ieee802-15-4')
+source=('git+https://github.com/bastibl/gr-ieee802-15-4')
+sha1sums=('SKIP')
+_gitname=gr-ieee802-15-4
+
+pkgver() {
+ cd "$_gitname"
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd "$_gitname"
+ git checkout master
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../
+ make
+}
+
+package() {
+ cd "$_gitname"
+ cd build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: