summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle McNally2017-02-09 09:43:11 -0500
committerKyle McNally2017-02-09 09:43:11 -0500
commit01b428b5e936ece779159365658374de5a0ce373 (patch)
treeef6769c37e6d85642d1fe2953dd6306cc9ad3352
parent36b3232d7633045f7ae0b8ed008b332bd769327f (diff)
downloadaur-01b428b5e936ece779159365658374de5a0ce373.tar.gz
upstream update to 0.10.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ae487ec9193..f837d04eecc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = greyhole
pkgdesc = Application that uses Samba to create a storage pool of all your available hard drives and allows you to create redundant copies of the files you store, in order to prevent data loss when part of your hardware fails.
- pkgver = 0.9.67
+ pkgver = 0.10.0
pkgrel = 1
url = https://www.greyhole.net/
install = greyhole.install
@@ -13,10 +13,10 @@ pkgbase = greyhole
depends = lsof
depends = sysstat
backup = etc/greyhole.conf
- source = https://greyhole.net/releases/greyhole-0.9.67.tar.gz
+ source = https://greyhole.net/releases/greyhole-0.10.0.tar.gz
source = greyhole.service
- md5sums = bfb135c29f881024a59d66fda4c650c9
- md5sums = 667531c2298d018f8487bfbb58f0a94d
+ sha256sums = bd158d58d9ccdb953ec6dd09c2f2f26d6983d1c0ac36d9eb4228cd1db374d663
+ sha256sums = f09cc153424934f2e7e0d8b66cdb47bd5f331640388202917533115d53962ef9
pkgname = greyhole
diff --git a/PKGBUILD b/PKGBUILD
index 3262fe42c67b..549781a2b6fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Christopher Krooß <didi2002@web.de>
pkgname=greyhole
-pkgver=0.9.67
+pkgver=0.10.0
pkgrel=1
-pkgdesc="Application that uses Samba to create a storage pool of all your available hard drives and allows you to create redundant copies of the files you store, in order to prevent data loss when part of your hardware fails."
+pkgdesc='Application that uses Samba to create a storage pool of all your available hard drives and allows you to create redundant copies of the files you store, in order to prevent data loss when part of your hardware fails.'
arch=('x86_64')
url="https://www.greyhole.net/"
license=('GPL3')
@@ -14,15 +14,15 @@ backup=('etc/greyhole.conf')
install='greyhole.install'
source=("https://greyhole.net/releases/$pkgname-$pkgver.tar.gz"
"greyhole.service")
-md5sums=('bfb135c29f881024a59d66fda4c650c9'
- '667531c2298d018f8487bfbb58f0a94d')
+sha256sums=('bd158d58d9ccdb953ec6dd09c2f2f26d6983d1c0ac36d9eb4228cd1db374d663'
+ 'f09cc153424934f2e7e0d8b66cdb47bd5f331640388202917533115d53962ef9')
package() {
cd "$pkgname-$pkgver"
mkdir -p "$pkgdir/var/spool/greyhole"
chmod 777 "$pkgdir/var/spool/greyhole"
- mkdir -p "$pkgdir/usr/share/greyhole"
+ mkdir -p "$pkgdir/usr/share/greyhole/scripts-examples"
install -m 0755 -D -p greyhole "$pkgdir/usr/bin/greyhole"
install -m 0755 -D -p greyhole-dfree "$pkgdir/usr/bin/greyhole-dfree"
install -m 0755 -D -p greyhole-dfree.php "$pkgdir/usr/share/greyhole"
@@ -36,6 +36,10 @@ package() {
install -m 0644 -D -p docs/greyhole.conf.5.gz "$pkgdir/usr/share/man/man5/greyhole.conf.5.gz"
install -m 0644 -D -p USAGE "$pkgdir/usr/share/greyhole/USAGE"
install -m 0644 -D -p schema-mysql.sql "$pkgdir/usr/share/greyhole/schema-mysql.sql"
+ install -m 0755 -D -p scripts-examples/greyhole_file_changed.sh "$pkgdir/usr/share/greyhole/scripts-examples/greyhole_file_changed.sh"
+ install -m 0755 -D -p scripts-examples/greyhole_idle.sh "$pkgdir/usr/share/greyhole/scripts-examples/greyhole_idle.sh"
+ install -m 0755 -D -p scripts-examples/greyhole_notify_error.sh "$pkgdir/usr/share/greyhole/scripts-examples/greyhole_notify_error.sh"
+ install -m 0755 -D -p scripts-examples/greyhole_send_fsck_report.sh "$pkgdir/usr/share/greyhole/scripts-examples/greyhole_send_fsck_report.sh"
install -m 0644 -D -p "$srcdir/greyhole.service" "$pkgdir/usr/lib/systemd/system/greyhole.service"
@@ -75,9 +79,9 @@ package() {
install -m 644 "samba-module/bin/4.3/$_vfs_file" $pkgdir/usr/lib/greyhole/greyhole-samba43.so"
ln -s "/usr/lib/greyhole/greyhole-samba43.so" $pkgdir/usr/lib/samba/vfs/greyhole.so"
;;
- 44 )
- install -m 644 "samba-module/bin/4.4/$_vfs_file" "$pkgdir/usr/lib/greyhole/greyhole-samba44.so"
- ln -s "/usr/lib/greyhole/greyhole-samba44.so" "$pkgdir/usr/lib/samba/vfs/greyhole.so"
+ 45 )
+ install -m 644 "samba-module/bin/4.5/$_vfs_file" "$pkgdir/usr/lib/greyhole/greyhole-samba45.so"
+ ln -s "/usr/lib/greyhole/greyhole-samba45.so" "$pkgdir/usr/lib/samba/vfs/greyhole.so"
;;
* )
echo "Incompatible Samba version: Please see https://github.com/gboudreau/Greyhole/blob/master/INSTALL for manual build directions"