summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordllud2024-04-29 17:03:14 +0100
committerdllud2024-04-29 17:06:27 +0100
commita63ccc8d0513f3f62690f9cf2a84f9453a234152 (patch)
tree8ae92c34fd1ab5af60e8f806c78057988d44f27f
parent25180708900c74174e6d2a5ba515e573b4960326 (diff)
downloadaur-grin-wallet.tar.gz
Update to v5.3.0
Adhere to Arch's Rust package guidelines. Disable lto. Build fails with it. Use proper SPDX license identifier.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbf2600af469..cf1411434fb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = grin-wallet
pkgdesc = Reference implementation of Grin's wallet.
- pkgver = 5.1.0
+ pkgver = 5.3.0
pkgrel = 1
url = https://github.com/mimblewimble/grin-wallet
arch = i686
arch = x86_64
- license = Apache
- makedepends = clang
- makedepends = rust
+ license = Apache-2.0
+ makedepends = cargo
optdepends = tor: for immediate transactions through Tor anonymizing network
- source = grin-wallet-5.1.0.tar.gz::https://github.com/mimblewimble/grin-wallet/archive/v5.1.0.tar.gz
- b2sums = b681b173b76d4d4ffbe72321ad568b533fffdcb43f590ac72b1e103c695826b6a09fe237018c5cca0ea3054cd453232c14bf784f104c18be6a878ec7b933d561
+ options = !lto
+ source = grin-wallet-5.3.0.tar.gz::https://github.com/mimblewimble/grin-wallet/archive/v5.3.0.tar.gz
+ b2sums = 1785645e8a6f14727decdf29ad4ec89ab2b6514e025806be8016cc8604401d699cdfd7b48d5f2b2a3859a02acc54a042d44d55d68a695d6af9bac1d54a542f0a
pkgname = grin-wallet
diff --git a/PKGBUILD b/PKGBUILD
index 48b9767287d9..35960eef73e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,31 @@
# Maintainer: dllud <dllud riseup net>
pkgname=grin-wallet
-pkgver=5.1.0
+pkgver=5.3.0
pkgrel=1
pkgdesc="Reference implementation of Grin's wallet."
arch=('i686' 'x86_64')
url='https://github.com/mimblewimble/grin-wallet'
-license=('Apache')
+license=('Apache-2.0')
optdepends=('tor: for immediate transactions through Tor anonymizing network')
-makedepends=('clang' 'rust')
+makedepends=('cargo')
source=("$pkgname-$pkgver.tar.gz::https://github.com/mimblewimble/grin-wallet/archive/v$pkgver.tar.gz")
-b2sums=('b681b173b76d4d4ffbe72321ad568b533fffdcb43f590ac72b1e103c695826b6a09fe237018c5cca0ea3054cd453232c14bf784f104c18be6a878ec7b933d561')
+b2sums=('1785645e8a6f14727decdf29ad4ec89ab2b6514e025806be8016cc8604401d699cdfd7b48d5f2b2a3859a02acc54a042d44d55d68a695d6af9bac1d54a542f0a')
+options=(!lto)
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
build() {
cd "${pkgname}-${pkgver}"
- cargo build --release
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ cargo test --frozen --all-features
}
package() {