summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2019-01-27 18:22:58 +0100
committerHector Martinez-Seara2019-01-27 18:22:58 +0100
commit5df5c555af90feb97f5b3db7b30028c75f8a2087 (patch)
tree4b99e5adcc97124b0f2b2e8051892323f3ac6459
parent0a7c240bec79dd61f9a134ef1765f997e132e387 (diff)
downloadaur-gromacs-5.1-complete.tar.gz
Compilation using GCC7 that is compatible with cuda10
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 938831089043..995428d0896b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gromacs-5.1-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 5.1.5
- pkgrel = 1
+ pkgrel = 2
url = http://www.gromacs.org/
arch = i686
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = gromacs-5.1-complete
makedepends = cmake
makedepends = libxml2
makedepends = hwloc
+ makedepends = gcc7
depends = lapack
depends = zlib
depends = libx11
diff --git a/PKGBUILD b/PKGBUILD
index 773753ff8330..866a610be799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gromacs-5.1-complete
pkgver=5.1.5
-pkgrel=1
+pkgrel=2
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
@@ -11,7 +11,7 @@ depends=('lapack' 'zlib' 'libx11')
optdepends=('cuda: Nvidia GPU support'
'openmotif: needed for gmx view'
'perl: needed for demux.pl and xplor2gmx.pl')
-makedepends=('cmake' 'libxml2' 'hwloc')
+makedepends=('cmake' 'libxml2' 'hwloc' 'gcc7')
options=('!libtool')
source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
GMXRC.bash.cmakein.patch)
@@ -23,9 +23,9 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#trajectory file format that can be read by
#VMD installation (e.g. AMBER's DCD format).
-export CC=gcc-6
-export CXX=g++-6
-export CFLAGS="-march=native -O2 -pipe -fstack-protector-strong -fno-plt"
+export CC=gcc-7
+export CXX=g++-7
+export CFLAGS="-march=native -O2 -pipe -fstack-protector-strong"
export CXXFLAGS="${CFLAGS}"
prepare() {